1025. PAT Ranking (25)

题目:

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
注意:
1、这一题比较纠结的地方在于会出现很多成绩并列的情况,处理好这一点之后基本上就不会有什么问题了。
2、需要注意的是成绩需要从高到低排列,而成绩相同时需要ID从小到大排列。

代码:
#include<iostream>
#include<vector>
#include<string>
#include<algorithm>
using namespace std;
struct testee
{
	string id;
	int score;
	int location_number;
	int local_rank;
	bool operator < (const testee &t) const
	{
		if(score==t.score)
			return id>t.id;//note when score=t.score sort by id
		else
			return score<t.score;
	}
};
vector<testee>lists;
int N;//number of list
int total=0;//total number of testees

int main()
{
	cin>>N;
	for(int i=0;i<N;++i)
	{
		int k;
		testee tes;
		cin>>k;
		total+=k;
		for(int j=0;j<k;++j)
		{
			cin>>tes.id>>tes.score;
			tes.location_number=i+1;
			lists.push_back(tes);
		}
		std::sort(lists.begin()+total-k,lists.end());
		lists[total-1].local_rank=1;
		for(int j=total-2;j>=total-k;--j)
		{ //if his score is the same with the previous testee, so is his rank
			if(lists[j].score==lists[j+1].score)
				lists[j].local_rank=lists[j+1].local_rank;
			else lists[j].local_rank=total-j;
		}
	}
	cout<<total<<endl;
	std::sort(lists.begin(),lists.end());
	int final_rank=1;
	int curScore=101;
	for(int i=total-1;i>=0;--i)
	{
		if(lists[i].score<curScore)
		{ //note that when lists[i].score==curScore,final_rank is the same with the previous testee
			curScore=lists[i].score;
			final_rank=total-i;
		}
		cout<<lists[i].id<< ' '<<final_rank<<' '<<lists[i].location_number<< ' '<<lists[i].local_rank<<endl;
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值