1056. Mice and Rice (25)

题目:

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP programmers. Then every NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NGwinners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP and NG (<= 1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi (i=0,...NP-1) where each Wiis the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,...NP-1 (assume that the programmers are numbered from 0 to NP-1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
Sample Output:
5 5 5 2 5 5 5 3 1 3 5

注意:
1、赶脚这道题目读懂题目比写出代码要难多了。。。
2、把题目中的例子分析一遍你就懂了:
     1)input中的第三行是索引,表示的是以第三行索引的顺序进行比较,也就是说第6、0、8个mice先组成一组进行比较,而这3个mice吃到的rice就是第二行中对应的值19、25、57,因此第8个mice吃到的是57数量最多晋级,同理第7、10、5个mice吃到的rice是22、10、3,第7个晋级,第9、1、4个mice吃到的rice是56、18、37,第9个晋级,剩下的只有第2、3个mice,分别吃到的rice是0、46,第3个晋级,于是第8、7、9、3一共4个mice晋级到下一轮,并继续按照这个顺序比较,那么其他没有晋级的mice的排名都是第5名。
     2)第8、7、9、3个mice吃到的rice分别是57、22、56、46,前三个中第8个晋级,剩下的第3个也晋级,所以未晋级的7、9的排名都是第3。
     3)第8、3个mice的排名分别是第1和第2了。
3、这里有一点比较关键的就是未晋级的mice的排名名次的计算,知道了当前要比赛的mice的数量之后就可以计算出一共会有多少晋级,那么未晋级的mice的名次就都是本轮晋级数目+1了。

代码:
//1056
#include<iostream>
#include<vector>
using namespace std;

int main()
{
	int np,ng;
	scanf("%d%d",&np,&ng);
	vector<int>weight,order,rank;
	weight.resize(np);
	order.resize(np);
	rank.resize(np);
	for(int i=0;i<np;++i)
		scanf("%d",&weight[i]);
	for(int i=0;i<np;++i)
		scanf("%d",&order[i]);
	int curRank=0;
	while(order.size()>1)
	{
		//if there are n competiter,then ceil(n/ng) is the number of competiter 
		//who will enter the next turn,the other's rank = ceil(n/ng)+1
		curRank=order.size()/ng+1;
		if(order.size()%ng>0)
			++curRank;
		vector<int>next;
		next.clear();
		int n=0;
		while(n<order.size())
		{//find the competiter of the next turn
			int max=-1,index=0;
			for(int i=0;i<ng && n<order.size();++i,++n)
			{//ng competiter a group to find the winner and push to the next turn
				rank[order[n]]=curRank;
				if(weight[order[n]]>max)
				{
					max=weight[order[n]];
					index=order[n];
				}
			}
			next.push_back(index);
		}
		order=next;
	}
	rank[order[0]]=1;
	printf("%d",rank[0]);
	for(int i=1;i<np;++i)
		printf(" %d",rank[i]);
	return 0;
}

  • 6
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值