关闭

Webspear 配置解决JSPG0049E配置问题

标签: SPG0049E webspear js
606人阅读 评论(0) 收藏 举报
分类:

Webspear 配置

一:解决的问题:

按照该文档配置解决的问题是:管控平台报错的问题。

二:错误分析:

错误消息:JSPG0049E: /xx /xxxx.jsp 无法编译。根据提示信息查看代码,List加泛型后会出现该错误,jdk1.5已经有了泛型。

 

三:解决方式:

编辑:ibm-web-ext.xmi文件

在里面增加一行

<jspAttributes xmi:id="JSPAttribute_jdkSourceLevel"name="jdkSourceLevel" value="15"/>

  如下图所示:

   


  停止WAS,清一下Profiles下面的temp目录,再启动即可。

  特别注意事项:

ibm-web-ext.xmi文件在webspear中有两个地方,都要加一下才行。一个是在config目录中我们的应用目录下下,一个是在installedApps目录中我们的应用目录下!

 

 四:修改后的效果图

           图公司不让发,看文章吧!

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:10872次
    • 积分:190
    • 等级:
    • 排名:千里之外
    • 原创:76篇
    • 转载:0篇
    • 译文:0篇
    • 评论:0条
    文章分类