Webspear 配置解决JSPG0049E配置问题

Webspear 配置

一:解决的问题:

按照该文档配置解决的问题是:管控平台报错的问题。

二:错误分析:

错误消息:JSPG0049E: /xx /xxxx.jsp 无法编译。根据提示信息查看代码,List加泛型后会出现该错误,jdk1.5已经有了泛型。

 

三:解决方式:

编辑:ibm-web-ext.xmi文件

在里面增加一行

<jspAttributes xmi:id="JSPAttribute_jdkSourceLevel"name="jdkSourceLevel" value="15"/>

  如下图所示:

   


  停止WAS,清一下Profiles下面的temp目录,再启动即可。

  特别注意事项:

ibm-web-ext.xmi文件在webspear中有两个地方,都要加一下才行。一个是在config目录中我们的应用目录下下,一个是在installedApps目录中我们的应用目录下!

 

 四:修改后的效果图

           图公司不让发,看文章吧!

阅读更多
文章标签: SPG0049E webspear js
个人分类: Java
想对作者说点什么? 我来说一句

win7下jdk1.7环境变量的配置

2012年12月21日 732KB 下载

PHP之环境配置

2012年05月28日 54KB 下载

没有更多推荐了,返回首页

不良信息举报

Webspear 配置解决JSPG0049E配置问题

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭