HDU 4405 Aeroplane chess(概率dp)

34 篇文章 1 订阅
28 篇文章 0 订阅

Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3119    Accepted Submission(s): 1993


Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

Input
There are multiple test cases.
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0.
 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

Sample Input
  
  
2 0 8 3 2 4 4 5 7 8 0 0
 

Sample Output
  
  
1.1667 2.3441
 

Source
 

Recommend
zhoujiaqi2010


题目大意:

    玩飞行棋,有一个骰子可以走1~6步,还有一些航线可以直接从一个格子移动到前面的一个格子。求走到终点的步数期望。


解题思路:

    从终点到起点递推,如果一个格子有航线,那么它的期望就是航线所连接的前面的格子的期望,否则它的期望就是前面6步格子期望除以6再加一。


附AC代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;

const int maxn=100000+5;
int path[maxn],n,m;
double dp[maxn];

int main()
{
    while(~scanf("%d%d",&n,&m)&&(n||m))
    {
        memset(path,-1,sizeof path);//-1表示没有航线
        for(int i=0;i<m;++i)
        {
            int from;
            scanf("%d",&from);
            scanf("%d",&path[from]);
        }
        memset(dp,0,sizeof dp);//初始期望为0
        for(int i=n-1;i>=0;--i)
        {
            if(path[i]!=-1)//有航线
                dp[i]=dp[path[i]];
            else
            {
                for(int j=1;j<=6;++j)
                    dp[i]+=dp[i+j];
                dp[i]=dp[i]/6+1;
            }
        }
        printf("%.4f\n",dp[0]);
    }
    
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值