HDOJ Hatsune Miku 5074【2014鞍山区域赛E题-动态规划】

Hatsune Miku

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 878    Accepted Submission(s): 616


Problem Description
Hatsune Miku is a popular virtual singer. It is very popular in both Japan and China. Basically it is a computer software that allows you to compose a song on your own using the vocal package.

Today you want to compose a song, which is just a sequence of notes. There are only m different notes provided in the package. And you want to make a song with n notes.


Also, you know that there is a system to evaluate the beautifulness of a song. For each two consecutive notes a and b, if b comes after a, then the beautifulness for these two notes is evaluated as score(a, b).

So the total beautifulness for a song consisting of notes a 1, a 2, . . . , a n, is simply the sum of score(a i, a i+1) for 1 ≤ i ≤ n - 1.

Now, you find that at some positions, the notes have to be some specific ones, but at other positions you can decide what notes to use. You want to maximize your song’s beautifulness. What is the maximum beautifulness you can achieve?
 

Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains two integers n(1 ≤ n ≤ 100) and m(1 ≤ m ≤ 50) as mentioned above. Then m lines follow, each of them consisting of m space-separated integers, the j-th integer in the i-th line for score(i, j)( 0 ≤ score(i, j) ≤ 100). The next line contains n integers, a 1, a 2, . . . , a n (-1 ≤ a i ≤ m, a i ≠ 0), where positive integers stand for the notes you cannot change, while negative integers are what you can replace with arbitrary notes. The notes are named from 1 to m.
 

Output
For each test case, output the answer in one line.
 

Sample Input
  
  
2 5 3 83 86 77 15 93 35 86 92 49 3 3 3 1 2 10 5 36 11 68 67 29 82 30 62 23 67 35 29 2 22 58 69 67 93 56 11 42 29 73 21 19 -1 -1 5 -1 4 -1 -1 -1 4 -1
 

Sample Output
  
  
270 625
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   5352  5351  5350  5349  5348 
 

题意:给出一个长度为n的序列,例如a1,a2,a3,a4......an,然后这个序列的美丽值就是s[a1][a2] + s[a2][a3] + ..... s[an-1][an],但是这个序列里面并不是所有的数都是确定的,输入包含一些大于0的数和一些-1,-1表示这个数可以任意,但是要在m的范围内,给出s[i][j],求这个序列最大的美丽值.

动态规划~

递推式:

dp[i+1][k]=max(dp[i+1][k],dp[i][j]+s[j][k]);

#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

int s[51][51]; //记录矩阵 
int dp[101][51];//记录i位置选j时的最大值 
int a[110];// 记录n数列
int n,m;

int solve()
{
	memset(dp,-1,sizeof(dp));//不存在的值赋值为-1
	int res=-1;
	for(int i=1;i<=m;i++)//第一位上不管取什么都为0 
		dp[1][i]=0;
	for(int i=1;i<=n;i++){ //遍历每一位数 
		for(int j=1;j<=m;j++){//遍历m 
			if(a[i]>0&&j!=a[i]){ //如果a[i]!=-1并且a[i]!=j,j是选的数 
				dp[i][j]=-1;
				continue;
			}
			if(dp[i][j]==-1)continue;//不存在直接返回继续 
			if(i==n){ //i==n 就遍历每个m 然后找出最大值 
				res=max(res,dp[i][j]);
				continue;
			}
			for(int k=1;k<=m;k++){//判断每一位是否需要加上s[j][k] 
				dp[i+1][k]=max(dp[i+1][k],dp[i][j]+s[j][k]);
			}
		}
	}
	return res;
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&n,&m);
		for(int i=1;i<=m;i++) //下标从1开始比较容易 
			for(int j=1;j<=m;j++){
				scanf("%d",&s[i][j]);
			}
		for(int i=1;i<=n;i++){
			scanf("%d",&a[i]);
		}
		int ans=solve();
		printf("%d\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值