UVA11044 Searching for Nessy

本文探讨了如何在模拟尼斯湖的网格中,使用最少的声纳设备覆盖所有区域,以确保能探测到任何可能存在的神秘生物。根据条件,每个声纳占据一格,控制自身及相邻格子,并且边界不需要覆盖。给出了样例输入和输出,帮助理解解题策略。
摘要由CSDN通过智能技术生成


 Searching for Nessy 

The Loch Ness Monsterisa mysterious and unidentified animal said to inhabit Loch Ness, 
a large deep freshwaterloch near the cityof Inverness in northern Scotland. Nessie is usually categorized as a type oflake monster.

http://en.wikipedia.org/wiki/Loch_Ness_Monster


In July 2003, the BBC reported an extensive investigation of Loch Ness by a BBCteam, using 600 separate sonar beams, found no trace of any ¨sea monster¨(i.e., any large animal, known or unknown) in the loch. The BBC team concludedthat Nessie does not exist. Now we want to repeat the experiment.


Given a grid of n rows and m columns representing the loch, 6$ \le$n, m$ \le$10000, find the minimum number s of sonar beams you must put in the square such that we can control every position in thegrid, with the following conditions:

  • one sonar occupies one position in the grid; the sonar beam controls its own cell and the contiguous cells;
  • the border cells do not need to be controlled, because Nessy cannot hide there (she is too big).

For example,


$\textstyle \parbox{.5\textwidth}{\begin{center}\mbox{}\epsfbox{p11044.eps}\end{center}}$$\textstyle \parbox{.49\textwidth}{\begin{center}\mbox{}\epsfbox{p11044a.eps}\end{center}}$

\epsfbox{p11044b.eps}

where X represents a sonar, and the shaded cells are controlled bytheir sonar beams; the last figure gives us a solution.

Input

The first line of the input contains an integer, t, indicating the number of test cases. For eachtest case, there is a line with two numbers separated by blanks, 6$ \le$n, m$ \le$10000, that is, the size of the grid (n rows and m columns).

Output

For each test case, the output should consist of one line showing the minimumnumber of sonars that verifies the conditions above.

Sample Input

 
3
6 6
7 7
9 13

Sample Output

 
4
4
12

题目意思就是一个探测器能覆盖探测一个九宫格,问最少几个探测器能把整个范围覆盖,边缘不需要。
很水的一道题。。还故意把例子中第二个例子画的那么复杂。。。其实就是把 长减去2 在除以3 (意思就是这个长度要几个探测器。如果不能整除就+1个) 宽也是。相乘即可。。。

AC代码 :


#include<stdio.h>

int main () {

	int T;
	int row,colum;
	int rrow,rcolum;
	scanf("%d",&T);
	while (T--) {
	
		scanf("%d%d",&row,&colum);
		row = row - 2;
		colum = colum - 2;
		rrow = row / 3;
		if (row % 3 != 0)
			rrow += 1;
		rcolum = colum / 3;
		if (colum % 3 != 0)
			rcolum += 1;
		printf("%d\n",rrow * rcolum);

	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值