动态规划:HDU1003-Max Sum(最大子串和)

 

Max Sum

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 81735    Accepted Submission(s): 18797


 

Problem Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

 

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

 

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

 

 

Sample Input

 

2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5

 

 

Sample Output

 

Case 1: 14 1 4 Case 2: 7 1 6

 

 

 

解题心得:

1、这个题要求的是一个在序列中的一串连续的子序列,要求子序列的和最大,并且要求记录子序列的起始位置和终止位置。

2、可以将前面的数加在一起看作一个数,当前面的数为负数的时候则舍去,将当前这个数作为新的起点。用一个变量Max记录一下最大的值,当最大值被替换的时候记录一下终点和起点。理解了还是很容易的。

 

 

 

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e5+100;
int num[maxn],dp[maxn];
int Start,End,now_start,Max;
int main()
{
    int t;
    int T;
    scanf("%d",&t);
    T = t;
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        num[0] = -1;
        now_start = 1;
        Max = -1000000;
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&num[i]);
        for(int i=1;i<=n;i++)
        {
            if(num[i] + dp[i-1] >= num[i])//前面的数不是负数
                dp[i] = num[i] + dp[i-1];
            else
            {
                dp[i] = num[i];//前面一个数是负数,将现在这个数作为新的起点
                now_start = i;//当前起点,当出现最大值的用得到
            }
            if(dp[i] >= Max)//出现最大值,记录最大值,终点和起点
            {
                Start = now_start;
                End = i;
                Max = dp[i];
            }
        }
        printf("Case %d:\n",T-t);
        if(t != 0)
            printf("%d %d %d\n\n",Max,Start,End);
        else
            printf("%d %d %d\n",Max,Start,End);
    }
    return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值