数学算法:求多个数的最小公倍数

解体心得:
1、一开始我的算法是找出最大的那个数,再将那个数一倍一倍的相加,但是会超时,因为题目的限制是32bits。(过于天真)
2、运用小学奥数的算法,多个数的最小公倍数,先将两个数的最小公倍数求出,再与后面的数求最小公倍数。两个数的最小公倍数,可以先将两个数相乘再除两个数的最小公因数。为了避免溢出,可以先相除再相乘。
3、有一个比较简单的求最大公因数的库函数调用(__gcd(int a,int b)),但不是标准库,头文件使用万能头文件。

题目:

Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.



Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.


Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.


Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1


Sample Output
105
10296


Source
East Central Northmerica 2003, Practice 
#include<bits/stdc++.h>
using namespace std;
//为了防止溢出全开long long,gcd函数是找出两个数的最大公因数(辗转相除法);
long long gcd(long long a,long long k)
{
    if(k == 0)
        return a;
    else
        return gcd(k,a%k);
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        long long k,cnt,a;
        a = cnt = 1;
        while(n--)
        {
            cin>>k;//一边输入一边计算,节省时间
            cnt = a/gcd(a,k)*k;//先除后乘防止溢出;
            a = cnt;
        }
        cout<<cnt<<endl;
    }
}

求最大公因数的库函数使用:

#include<bits/stdc++.h>
//好像只能使用这个头文件
using namespace std;
int main()
{
    int a,b;
    while(scanf("%d%d",&a,&b)!=EOF)
    {
        printf("%d\n",__gcd(a,b));
//不是标准库中的函数
    }
}
  • 2
    点赞
  • 11
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值