NYOJ 题目148 fibonacci数列(二)(矩阵快速幂)



fibonacci数列(二)

时间限制: 1000  ms  |  内存限制: 65535  KB
难度: 3
描述

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

输入
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
输出
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
样例输入
0
9
1000000000
-1
样例输出
0
34
6875
来源
POJ
上传者
hzyqazasdf

ac代码

#include<stdio.h>
#include<string.h>
#define mod 10000
struct s
{
	int mp[2][2];
};
struct s p=
{
	1,1,
	1,0,
};
struct s a=
{
	1,0,
	0,1,
};
struct s muti(struct s a,struct s b)
{
	struct s c;
	int i,j,k;
	memset(c.mp,0,sizeof(c.mp));
	for(i=0;i<2;i++)
		for(j=0;j<2;j++)
		{
			for(k=0;k<2;k++)
			{
				c.mp[i][j]+=(a.mp[i][k]*b.mp[k][j])%mod;
			}
			c.mp[i][j]%=mod;
		}
		return c;
}
struct s fun(int n)
{
	struct s ta=a,tp=p;
	while(n)
	{
		if(n&1)
			ta=muti(ta,tp);
		tp=muti(tp,tp);
		n/=2;
	}
	return ta;
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF,n!=-1)
	{
		struct s ans;
		memset(ans.mp,0,sizeof(ans.mp));
		ans=fun(n);
		printf("%d\n",ans.mp[1][0]);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值