Fibonacci————矩阵快速幂求斐波那契数列

题目:

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

 

题意:

给一个数n,让求斐波那契数列的第n项的后四位;

 

思路:

因为n可以很大,所以利用矩阵快速幂求;

 

代码:

 

#include<stdio.h>
#include<iostream>
#include<string>
#include<string.h>
#include<math.h>
#include<queue>
#include<map>
#include<stack>
#include<string>
#include<algorithm>
#define ll long long
#define N 1008611
#define inf 0x3f3f3f3f
using namespace std;
struct node
{
    ll a[5][5];
};
node solve(node x,node y)//两矩阵相乘
{
    node ans;
    memset(ans.a,0,sizeof(ans.a));
    for(int i=0;i<2;i++)
    {
        for(int j=0;j<2;j++)
        {
            for(int k=0;k<2;k++)
            {
                ans.a[i][k]+=x.a[i][j]*y.a[j][k]%10000;
                ans.a[i][k]%=10000;
            }
        }
    }
    return ans;
}
node quicklymod(node s,ll n)//矩阵快速幂
{
    node ans;
    ans.a[0][0]=1;ans.a[0][1]=0;
    ans.a[1][0]=0;ans.a[1][1]=1;//单位矩阵
    while(n)
    {
        if(n&1)
            ans=solve(s,ans);
        s=solve(s,s);
        n>>=1;
    }
    return ans;
}
int main()
{
    ll n;
    while(~scanf("%lld",&n)&&n!=-1)
    {
        if(n==0)
        {
            printf("0\n");
            continue;
        }
        node s;
        s.a[0][0]=1;s.a[0][1]=1;
        s.a[1][0]=1;s.a[1][1]=0;
        node ans=quicklymod(s,n-1);
        printf("%lld\n",ans.a[0][0]);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值