HDOJ 题目3065 病毒侵袭持续中(AC自动机,求字串在母串出现个数)

病毒侵袭持续中

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8460    Accepted Submission(s): 2945


Problem Description
小t非常感谢大家帮忙解决了他的上一个问题。然而病毒侵袭持续中。在小t的不懈努力下,他发现了网路中的“万恶之源”。这是一个庞大的病毒网站,他有着好多好多的病毒,但是这个网站包含的病毒很奇怪,这些病毒的特征码很短,而且只包含“英文大写字符”。当然小t好想好想为民除害,但是小t从来不打没有准备的战争。知己知彼,百战不殆,小t首先要做的是知道这个病毒网站特征:包含多少不同的病毒,每种病毒出现了多少次。大家能再帮帮他吗?
 

Input
第一行,一个整数N(1<=N<=1000),表示病毒特征码的个数。
接下来N行,每行表示一个病毒特征码,特征码字符串长度在1—50之间,并且只包含“英文大写字符”。任意两个病毒特征码,不会完全相同。
在这之后一行,表示“万恶之源”网站源码,源码字符串长度在2000000之内。字符串中字符都是ASCII码可见字符(不包括回车)。
 

Output
按以下格式每行一个,输出每个病毒出现次数。未出现的病毒不需要输出。
病毒特征码: 出现次数
冒号后有一个空格,按病毒特征码的输入顺序进行输出。
 

Sample Input
  
  
3 AA BB CC ooxxCC%dAAAoen....END
 

Sample Output
  
  
AA: 2 CC: 1
Hint
Hit: 题目描述中没有被提及的所有情况都应该进行考虑。比如两个病毒特征码可能有相互包含或者有重叠的特征码段。 计数策略也可一定程度上从Sample中推测。
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2243  2825  3247  3341  2296 
ac代码
#include<stdio.h>
#include<string.h>
char str[2000020],key[1010][50];
int head,tail;
int vis[1010];
struct node  
{  
    node *fail;  
    node *next[27];  
    int cnt;  
    node()  
    {  
        fail=NULL;  
        cnt=0;  
        for(int i=0;i<27;i++)  
            next[i]=NULL;  
    }  
}*q[500050];  
node *root;  
void insert(char *s,int id)  
{  
    int temp,len,i;  
    node *p=root;  
    len=strlen(s);  
    for(i=0;i<len;i++)  
    {  
        temp=s[i]-'A';  
        if(p->next[temp]==NULL)  
            p->next[temp]=new node();  
        p=p->next[temp];  
    }  
    p->cnt=id;      
}  
void build_ac()  
{  
    q[tail++]=root;  
    while(head!=tail)  
    {  
        node *p=q[head++];  
        node *temp=NULL;  
        for(int i=0;i<27;i++)  
        {  
            if(p->next[i]!=NULL)  
            {  
                if(p==root)  
                    p->next[i]->fail=root;  
                else  
                {  
                    temp=p->fail;  
                    while(temp!=NULL)  
                    {  
                        if(temp->next[i]!=NULL)  
                        {  
                            p->next[i]->fail=temp->next[i];  
                            break;  
                        }  
                        temp=temp->fail;  
                    }  
                    if(temp==NULL)  
                    {  
                        p->next[i]->fail=root;  
                    }  
                }  
                q[tail++]=p->next[i];  
            }  
        }  
    }  
}  
void query()  
{  
    int len=strlen(str);  
    node *p=root,*temp;  
    for(int i=0;i<len;i++)  
    {  
		int x;
		if(str[i]>='A'&&str[i]<='Z')
			x=str[i]-'A';
		else
			x=26;
        while(p->next[x]==NULL&&p!=root)  
            p=p->fail;  
        p=p->next[x];  
        if(p==NULL)  
        {  
            p=root;  
        }  
        temp=p;  
        while(temp!=root&&temp->cnt!=0)
        {  
			vis[temp->cnt]++; 
            //temp->cnt=0;  
            temp=temp->fail;  
        }  
    }  
}  
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int i;
		head=tail=0;
		root=new node();
		for(i=1;i<=n;i++)
		{
			scanf("%s",key[i]);
			insert(key[i],i);
		}
		build_ac();
		scanf("%s",str);
		memset(vis,0,sizeof(vis));
		query();
		for(i=1;i<=n;i++)
		{
			if(vis[i])
			{
				printf("%s: %d\n",key[i],vis[i]);
			}
		}
	}
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值