SPOJ 题目694 Distinct Substrings(后缀数组,求不同的子串个数)

DISUBSTR - Distinct Substrings

no tags 

Given a string, we need to find the total number of its distinct substrings.

Input

T- number of test cases. T<=20;
Each test case consists of one string, whose length is <= 1000

Output

For each test case output one number saying the number of distinct substrings.

Example

Sample Input:
2
CCCCC
ABABA

Sample Output:
5
9

Explanation for the testcase with string ABABA: 
len=1 : A,B
len=2 : AB,BA
len=3 : ABA,BAB
len=4 : ABAB,BABA
len=5 : ABABA

Thus, total number of distinct substrings is 9.


ac代码

#include<stdio.h>      
#include<string.h>      
#include<algorithm>      
#include<iostream>      
using namespace std;    
int s[2002];   
char str[2002]; 
int sa[2002],t1[2002],t2[2002],c[2002];    
int rank[2002],height[2002];    
void build_sa(int s[],int n,int m)    
{    
    int i,j,p,*x=t1,*y=t2;    
    for(i=0;i<m;i++)    
        c[i]=0;    
    for(i=0;i<n;i++)    
        c[x[i]=s[i]]++;    
    for(i=1;i<m;i++)    
        c[i]+=c[i-1];    
    for(i=n-1;i>=0;i--)    
        sa[--c[x[i]]]=i;    
    for(j=1;j<=n;j<<=1)    
    {    
        p=0;    
        for(i=n-j;i<n;i++)    
            y[p++]=i;    
        for(i=0;i<n;i++)    
            if(sa[i]>=j)    
                y[p++]=sa[i]-j;    
        for(i=0;i<m;i++)    
            c[i]=0;    
        for(i=0;i<n;i++)    
            c[x[y[i]]]++;    
        for(i=1;i<m;i++)    
            c[i]+=c[i-1];    
        for(i=n-1;i>=0;i--)    
            sa[--c[x[y[i]]]]=y[i];    
        swap(x,y);    
        p=1;    
        x[sa[0]]=0;    
        for(i=1;i<n;i++)    
            x[sa[i]]=y[sa[i-1]]==y[sa[i]]&&y[sa[i-1]+j]==y[sa[i]+j]?p-1:p++;    
        if(p>=n)    
            break;    
        m=p;    
    }    
}    
void getHeight(int s[],int n)    
{    
    int i,j,k=0;    
    for(i=0;i<=n;i++)    
        rank[sa[i]]=i;    
    for(i=0;i<n;i++)    
    {    
        if(k)    
            k--;    
        j=sa[rank[i]-1];    
        while(s[i+k]==s[j+k])    
            k++;    
        height[rank[i]]=k;    
    }    
}    
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int i;
		scanf("%s",str);
		int len=strlen(str);
		for(i=0;i<len;i++)
		{
			s[i]=str[i];
		}
		s[len]=0;
		build_sa(s,len+1,128);
		getHeight(s,len);
		long long ans=(len)*(len+1)/2;
		for(i=1;i<=len;i++)
		{
			ans-=height[i];
		}
		printf("%lld\n",ans);
	}
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值