UVA 题目825 Walking on the Safe Side(DP)

Square City is a very easy place for people to walk around. The two-way streets run North-South or
East-West dividing the city into regular blocks. Most street intersections are safe for pedestrians to
cross. In some of them, however, crossing is not safe and pedestrians are forced to use the available
underground passages. Such intersections are avoided by walkers. The entry to the city park is on the
North-West corner of town, whereas the railway station is on the South-East corner.
Suppose you want to go from the park to the railway station, and do not want to walk more than
the required number of blocks. You also want to make your way avoiding the underground passages,
that would introduce extra delay. Your task is to determine the number of different paths that you can
follow from the park to the station, satisfying both requirements.
The example in the picture illustrates a city with 4 E-W streets and 5 N-S streets. Three intersections
are marked as unsafe. The path from the park to the station is 3 + 4 = 7 blocks long and there are 4
such paths that avoid the underground passages.
Input
The input begins with a single positive integer on a line by itself indicating the number
of the cases following, each of them as described below. This line is followed by a blank
line, and there is also a blank line between two consecutive inputs.
The first line of the input contains the number of East-West streets W and the number of NorthSouth
streets N. Each one of the following W lines starts with the number of an East-West street,
followed by zero or more numbers of the North-South crossings which are unsafe. Streets are numbered
from 1.
Output
For each test case, the output must follow the description below. The outputs of two
consecutive cases will be separated by a blank line.
The number of different minimal paths from the park to the station avoiding underground passages.
Sample Input
1
4 5
1
2 2
3 3 5
4
Sample Output
4
题目大意:一个t,t组测试数据,下n行,下边n行数据,每行先输入一个行号,然后后边有不定个数,表示这一行,这几个位置不能走,问从左上角走到右下角,只能向下和向右走,的方法数

ac代码

<span style="font-family: Arial, Helvetica, sans-serif;">#include<stdio.h></span>
#include<string.h>
#include<iostream>
#include<algorithm>
#define LL long long
using namespace std;
LL dp[1010][1010];
int map[1010][1010];
char str[3010];
int n,m;
void fun(char *str,int r)
{
    int i;
    int len=strlen(str);
    char *p;
    p=strtok(str," ");
    int mm;
    while(p!=NULL)
    {
       mm=atoi(p);
       map[r][mm]=1;
       p=strtok(NULL," ");
       if(p==NULL)
            break;
    }
}
void DP()
{
    int i,j;
    memset(dp,0,sizeof(dp));
    dp[1][1]=1;
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=m;j++)
        {
            if(i==1&&j==1)
                continue;
            if(map[i][j]==1)
                continue;
            else
                dp[i][j]=dp[i-1][j]+dp[i][j-1];
        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        //int n,m;
        int i;
        scanf("%d%d",&n,&m);
        memset(map,0,sizeof(map));
        for(i=0;i<n;i++)
        {
            int r;
            scanf("%d",&r);
            gets(str);
            fun(str,r);
        }
        DP();
        printf("%lld\n",dp[n][m]);
        if(t)
            printf("\n");
    }
}



                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值