poj2689--素数筛----筛两次

Prime Distance
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8409 Accepted: 2273

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

Source

Waterloo local 1998.10.17
这道题交了无数遍都是re,结果把int改成long long就a了,没弄懂啊==,还是自己太水了。
#include <iostream>
#include <string.h>
#include <math.h>
using namespace std;
const int n=50010;
const int maxn=1000010;
int dis[maxn],su[maxn];
int a[maxn];
int main()
{    int num=0;
     memset(a,0,sizeof(a));
     a[0]=1;
     a[1]=1;
     //int m=(int)sqrt(n+0.5);
     for(long long i=2;i<=n;i++)
     {
         if(!a[i])
         {
             for(long long j=i*i;j<=n;j=j+i)
             {
                 a[j]=1;
             }
            su[num++]=i;
         }
     }
     long long l,u;
     while(cin>>l>>u)
     {
         for(long long i=l;i<=u;i++)
         dis[i-l]=0;
         for(int i=0;i<num;i++)
         {
             long long j=l/su[i];
             if(j*su[i]>u)
             break;
             if(l%su[i])
             j++;
             if(j==1)
             j++;
             for(;j*su[i]<=u;j++)
             {
                 dis[j*su[i]-l]=1;
             }
         }
         long long pi;
         int maxx=-1;
         int minn=1000001;
         for(long long i=l;i<=u;i++)
         {
             if(!dis[i-l])
             {
                 pi=i;
                 break;
             }
         }
         if(pi==1)
         pi++;
         long long m1,m2,n1,n2;
         for(long long i=pi+1;i<=u;i++)
         {
             if(!dis[i-l])
             {
               if(i-pi<minn)
               {
                   minn=i-pi;
                   m1=pi;
                   m2=i;
               }
                if(i-pi>maxx)
                {
                    maxx=i-pi;
                    n1=pi;
                    n2=i;
                }
                pi=i;
             }
         }
         if(maxx!=-1&&minn!=1000001)
         cout<<m1<<","<<m2<<" are closest, "<<n1<<","<<n2<<" are most distant."<<endl;
         else
         cout<<"There are no adjacent primes."<<endl;
     }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值