Prime Distance(二次筛素数)

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

解题思路:

这题做得我都是泪,不断地TLE,好不容易优化好了,又RE,代码也写得很龊。就是正常的二次筛选素数。由于数据很大,第一次筛出46500以内的素数,再根据此筛选出区间内的素数。

注意:虽然给的数没有超int范围,但两数相乘是会超int范围的,我也是在这里RE了。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
const int N = 1000005;
const int M = 46500;
const int INF = 999999999;
bool notprime[N];
int prime_1[M + 1], prime_2[N];
int num_1 = 0, num_2;
void Prime1()  // 第一次筛出46500以内的素数
{
    memset(notprime, false, sizeof(notprime));
    for(int i = 2; i <= M; i++)
        if(!notprime[i])
        {
            prime_1[num_1++] = i;
            for(int j = 2 * i; j <= M; j += i)
                notprime[j] = true;
        }
}
void Prime2(int l, int u)  // 第二次筛出给定范围内的素数
{
    memset(notprime, false, sizeof(notprime));
    num_2 = 0;
    if(l < 2)
        l = 2;
    int k = sqrt(u * 1.0);
    for(int i = 0; i < num_1 && prime_1[i] <= k; i++)
    {
        int t = l / prime_1[i];
        if(t * prime_1[i] < l)
            t++;
        if(t <= 1)
            t = 2;
        for(int j = t; (long long)j * prime_1[i] <= u; j++)  // 相乘会超范围,用long long
            notprime[j * prime_1[i] - l] = 1;
    }
    for(int i = 0; i <= u - l; i++)
        if(!notprime[i])
            prime_2[num_2++] = i + l;
}
int main()
{
    int l, u, dis, a_1, b_1, a_2, b_2, minn, maxx;;
    Prime1();
    while(scanf("%d%d", &l, &u) != EOF)
    {
        minn = INF, maxx = -1;
        Prime2(l, u);
        if(num_2  < 2)
        {
            printf("There are no adjacent primes.\n");
            continue;
        }
        for(int i = 1; i < num_2 && prime_2[i] <= u; i++)
        {
            dis = prime_2[i] - prime_2[i - 1];
            if(dis > maxx)
            {
                a_1 = prime_2[i - 1];
                a_2 = prime_2[i];
                maxx = dis;
            }
            if(dis < minn)
            {
                b_1 = prime_2[i-1];
                b_2 = prime_2[i];
                minn = dis;
            }
        }
        printf("%d,%d are closest, %d,%d are most distant.\n", b_1, b_2, a_1, a_2);
    }
    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值