uva 11889 Benefit

                                                                                                                                                   Benefit

Recently Yaghoub is playing a new trick to sell some more. When somebody gives him A Tomans, he who never has appropriate changes, asks for B Tomans such that lowest common multiple of A and B equals to C and he will pay back a round bill. Or otherwise take some snack instead of the remaining of his money. He believes that finding such a number is hard enough that dissuades students from paying that.

You should write a program that help poor students giving the appropriate amount of money to Yaghoub. Of course if there are several answers you go for students' benefit which is the lowest of them.
Input

The first line begin with an integer T ( T<=100000), the number of tests. Each test that comes in a separate line contains two integers A and C ( 1<=A, C<=107).
Output

Print the lowest integer B such that LCM(A, B) = C in a single line. If no such integer exists, print "NO SOLUTION" instead. (Quotes for clarity)
Sample Input

3
2 6
32 1760
7 16

Sample Output

3
55
NO SOLUTION

 解题思路:        1. 如果c%a != 0 表示无解. 设b = c/a; 当gcd(a, b)==1时, 表示b就是要求的结果. 如果gcd(a,b) != 1;            那么lcm(a, b)一定小于c. 你想一想为什么会这样, 因为原本a中有一部份与结果b相同. 那么, 说明            a影响了b的值.        2. 例如: a = 12 = 2^2*3^1, b = 16 = 2^4, c = 48 =2^4*3^1;  b' = c/a = 4 = 2^2;            如果b'就是b与a不相同的部分. 那么我们求出的b‘ 如果gcd(a, b') != 1表明a有一部份影响了结果.            这样我们要求出原来的b, 就需要b'*gcd(a, b'), a/gcd(a, b');循环这个过程知道gcd(a, b') ==1为止.那么b'得到原本的结果b.

#include <iostream>
#include <stdio.h>
using namespace std;
int gcd(int a,int b)
{
    if(b==0) return a;
    return gcd(b,a%b);
}
int main()
{
    int t;
    int a,c;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&a,&c);
        if(c%a!=0)
        printf("NO SOLUTION\n");
        else
        {
            int b=c/a;
            int g=1;
            while(gcd(a,b)!=1)
            {
                g*=gcd(a,b);
                a=a/gcd(a,b);
            }
            printf("%d\n",b*g);
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值