Java 大数加减乘除 hdu 5047


acm.hdu.edu.cn/showproblem.php?pid=5047



Sawtooth

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1592    Accepted Submission(s): 622


Problem Description
Think about a plane:

● One straight line can divide a plane into two regions.
● Two lines can divide a plane into at most four regions.
● Three lines can divide a plane into at most seven regions.
● And so on...

Now we have some figure constructed with two parallel rays in the same direction, joined by two straight segments. It looks like a character “M”. You are given N such “M”s. What is the maximum number of regions that these “M”s can divide a plane ?

 

Input
The first line of the input is T (1 ≤ T ≤ 100000), which stands for the number of test cases you need to solve.

Each case contains one single non-negative integer, indicating number of “M”s. (0 ≤ N ≤ 10 12)
 

Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then an integer that is the maximum number of regions N the “M” figures can divide.
 

Sample Input
  
  
2 1 2
 

Sample Output
  
  
Case #1: 2 Case #2: 19

import java.io.*;
import java.math.*;
public class Main{
  public static BufferedReader cin=new BufferedReader(new InputStreamReader(System.in));
  public static BufferedWriter cout=new BufferedWriter(new OutputStreamWriter(System.out));
  public static void main(String []args) throws Exception{
    int T=Integer.parseInt(cin.readLine());//读取T组数据
    for(int nkase=1;nkase<=T;nkase++){
      cout.write("Case #"+nkase+": ");
      BigInteger N=new BigInteger(cin.readLine());//输入
      BigInteger ans=N.multiply/*乘法*/(N).multiply(BigInteger.valueOf(8)/*将int的  8转化为biginteger*/).subtract/*减法*/(N.multiply(BigInteger.valueOf(7))).add(BigInteger.valueOf(1));
      cout.write(ans.toString());//转化成字符串
      cout.newLine();//换行
    }
    cout.flush();
    cout.close();//关闭
  }
}
、、、、//m.divide(n)===m/n

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值