hdu 5047 java大数+思维

Think about a plane: 

● One straight line can divide a plane into two regions. 
● Two lines can divide a plane into at most four regions. 
● Three lines can divide a plane into at most seven regions. 
● And so on... 

Now we have some figure constructed with two parallel rays in the same direction, joined by two straight segments. It looks like a character “M”. You are given N such “M”s. What is the maximum number of regions that these “M”s can divide a plane ? 

Input
The first line of the input is T (1 ≤ T ≤ 100000), which stands for the number of test cases you need to solve. 

Each case contains one single non-negative integer, indicating number of “M”s. (0 ≤ N ≤ 10  12)
Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then an integer that is the maximum number of regions N the “M” figures can divide.
Sample Input
2
1
2
Sample Output
Case #1: 2
Case #2: 19
题意:

有一个上图样子的M形的折线,每次添加一个M进去,给一个n问你添加n个M之后能把矩形空间最多分成多少部分。


解题思路:

首先使用一个叫“画图”的软件模拟一下这个过程,你会发现一些规律:






发现新增的块数满足一个规律:新增=(n-1)*4*4+1

那么从第二项新增的开始满足一个等差数列(即上式)

那么求ans就是求前n项的和,用等差数列求和公式可推出:

ans=(16*n+2)*(n-1)/2+2      (n>=2)

ans=2                 (n==1)

推出来公式以后看数据范围比较大,用java的高精度可解。

import java.util.*;
import java.math.BigInteger;
import java.math.*;
public class Main {

	public static void main(String[] args) {
		Scanner scanner=new Scanner(System.in);
		int t=scanner.nextInt();
		
		BigInteger two=new BigInteger("2");
		BigInteger one=new BigInteger("1");
		BigInteger data16=new BigInteger("16");
			for(int cas=1;cas<=t;cas++)
			{
				String str=scanner.next();
				BigInteger a=new BigInteger(str);
				BigInteger ans=a.multiply(data16).add(two).multiply(a.subtract(one)).divide(two).add(two);
				
				System.out.print("Case #"+cas+": ");
				if(a.equals(one))
					System.out.println(two);
				else
				System.out.println(ans);
			}
	}
	

}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值