杭电5480Conturbatio

A - Conturbatio
Time Limit:3000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

There are many rook on a chessboard, a rook can attack the row and column it belongs, including its own place. 

There are also many queries, each query gives a rectangle on the chess board, and asks whether every grid in the rectangle will be attacked by any rook? 

Input

The first line of the input is a integer  T , meaning that there are  T  test cases. 

Every test cases begin with four integers  n , m , K , Q
K  is the number of Rook,  Q  is the number of queries. 

Then  K  lines follow, each contain two integers  x , y  describing the coordinate of Rook. 

Then  Q  lines follow, each contain four integers  x1, y1, x2, y2  describing the left-down and right-up coordinates of query. 

1\leq n , m , K , Q \leq 100,000

1\leq x \leq n , 1 \leq y \leq m

1\leq x1 \leq x2 \leq n , 1 \leq y1 \leq y2 \leq m

Output

For every query output "Yes" or "No" as mentioned above.

Sample Input

2
2 2 1 2
1 1
1 1 1 2
2 1 2 2
2 2 2 1
1 1
1 2
2 1 2 2

Sample Output

Yes
No
Yes
#include<stdio.h>
#include<string.h>
int main()
{
int t,n,m,k,q,x,y,x1,x2,y1,y2,i;
int via[100010],vis[100010];
scanf("%d",&t);
while(t--)
{
memset(via,0,sizeof(via));
memset(vis,0,sizeof(vis));
scanf("%d%d%d%d",&n,&m,&k,&q);
while(k--)
{
scanf("%d%d",&x,&y);
via[x]=1;
vis[y]=1;
}
for(i=2;i<=n;i++)
via[i]+=via[i-1];
for(i=2;i<=m;i++)
vis[i]+=vis[i-1];
while(q--)
{
int ans=0;
int anb=0;
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
       if(via[x2]-via[x1-1]==x2+1-x1||vis[y2]-vis[y1-1]==y2+1-y1)
printf("Yes\n");
else
printf("No\n");
}
}
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值