mac上更新ruby

原创 2016年08月29日 17:20:28

因为准备在项目中使用bootstrap,在安装bootstrap过程中提示需要Ruby的版本在1.9.2以上,而目前使用的Ruby版本是Mac系统自带的1.8.7。所以需要对Ruby进行升级。这里使用RVM对Ruby进行升级,升级过程如下:

1、安装 RVM

RVM:Ruby Version Manager,Ruby版本管理器,包括Ruby的版本管理和Gem库管理(gemset)


[ruby] view plain copy


  1. $ curl -L get.rvm.io | bash -s stable  


等待一段时间后就可以成功安装好 RVM。


[ruby] view plain copy


  1. $ source ~/.bashrc  
  2. $ source ~/.bash_profile  


测试是否安装正常


[ruby] view plain copy


  1. rvm -v  


2、用RVM升级Ruby


[ruby] view plain copy


  1. #查看当前ruby版本  
  2. $ ruby -v  
  3. ruby 1.8.7  
  4. #列出已知的ruby版本  
  5. $ rvm list known  
  6. #安装ruby 1.9.3  
  7. $ rvm install 1.9.3  


安装完成之后ruby -v查看是否安装成功。

Mac上更新Ruby版本

1、安装 RVM RVM:Ruby Version Manager,Ruby版本管理器,包括Ruby的版本管理和Gem库管理(gemset) [ruby] view p...
  • zhao15127334470
  • zhao15127334470
  • 2016年10月19日 21:37
  • 1359

Mac下升级ruby至最新版本

升级rubyMac OS自身安装的有ruby,但是版本较低,为2.0.x 而安装CocoaPods,最低版本是2.2查看ruby版本ruby --version安装homebrewruby -e "...
  • spring21st
  • spring21st
  • 2016年10月22日 16:10
  • 9362

Mac系统升级ruby的一些命令

1.Check your ruby version ruby -v 2.Install rvm bash -s stable   3.Install hom...
  • guolinming007
  • guolinming007
  • 2014年01月16日 13:43
  • 980

mac下升级ruby环境版本

mac下升级ruby环境版本在ios开发中会经常使用到cocoapods来管理第三方框架,在安装cocoapods的时候会涉及到ruby环境,有时候会因为版本过低会导致安装失败,本文主要讲一下如何升级...
  • Archer_sc
  • Archer_sc
  • 2016年07月27日 10:43
  • 8880

Mac 上更新 ruby

因为准备在项目中使用bootstrap,在安装bootstrap过程中提示需要Ruby的版本在1.9.2以上,而目前使用的Ruby版本是Mac系统自带的1.8.7。所以需要对Ruby进行升级。这里使用...
  • li_yangyang_li
  • li_yangyang_li
  • 2016年07月04日 13:14
  • 490

Mac上更新Ruby

因为准备在项目中使用bootstrap,在安装bootstrap过程中提示需要Ruby的版本在1.9.2以上,而目前使用的Ruby版本是Mac系统自带的1.8.7。所以需要对Ruby进行升级。这里使用...
  • qq_34047841
  • qq_34047841
  • 2016年07月04日 14:27
  • 146

更新ruby镜像

OS EI Capitan无法安装cocoapods和ruby2.3.1,填坑。 字数715 阅读45 评论0 喜欢0 今天工作之余心情不错,想从github上下载个饭否第三方客户端下...
  • SpringJustin
  • SpringJustin
  • 2016年07月06日 10:20
  • 2627

mac自带的rubygems的更新

mac 系统下会自带rubygems,但通常情况下版本会很低. 更新rubygems一般会要取得管理员权限才行. 升级、更新 $ sudo gem update --system ...
  • klabcxy36897
  • klabcxy36897
  • 2015年03月27日 11:49
  • 716

mac 升级 ruby

在lion下安装rails会提示你的ruby版本为1.8.7,而新版本的rails3.x需要1.9.x的ruby支持。 所以,必须对ruby进行升级,经过各种凌乱和不成功终于摸索出经验。现在记录一下...
  • EI__Nino
  • EI__Nino
  • 2014年05月29日 07:50
  • 2681

在Mac OS X上安装 Ruby运行环境 CocoaPods安装和使用教程

对于新入门的开发者,如何安装 Ruby和Ruby Gems 的运行环境可能会是个问题,本页主要介绍如何用一条靠谱的路子快速安装 Ruby 开发环境。 此安装方法同样适用于产品环境! 系统需求 ...
  • gwh111
  • gwh111
  • 2015年09月24日 11:41
  • 6644
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:mac上更新ruby
举报原因:
原因补充:

(最多只允许输入30个字)