POJ 2081 Recaman's Sequence

map水过2400ms+懒得改成hash了

 

Description

The Recaman's sequence is defined by a0 = 0 ; for m > 0, a m = a m−1 − m if the rsulting a m is positive and not already in the sequence, otherwise a m = a m−1 + m.
The first few numbers in the Recaman's Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 ...
Given k, your task is to calculate a k.

Input

The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000.
The last line contains an integer −1, which should not be processed.

Output

For each k given in the input, print one line containing a k to the output.

Sample Input

7
10000
-1

Sample Output

20
18658

 

#include <iostream>
#include <map>
using namespace std;
map<int,int> l;
map<int,int>::iterator it;
const int S=500010;
int a[S];
int main(){
    a[0]=0;
    l[0]=1;
    int i,j,k,tmp,n,max=0;
    for (i=1;i<S;i++){
        tmp=a[i-1]-i;
        it=l.find(tmp);
        if (tmp>0)
            if (it==l.end()){
                l[tmp]=1;
                a[i]=tmp;
                continue;
            }
        tmp=a[i-1]+i;
        if (tmp>max) max=tmp;
        a[i]=tmp;
        l[tmp]=1;
    }
    while (cin>>n,n>=0){
        cout<<a[n]<<endl;
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值