POJ 2601 Simple calculations 利用单调性,二分找出答案

看完题目后,得到公式a[i]=2*a[i-1]-a[i-2]+2*c[i-1];  YY发现a[n+1]随a[1]增大而增大,那么就对a[1]二分吧,精度1e-4,1A。

Simple calculations
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5989 Accepted: 3040

Description

There is a sequence of n+2 elements a 0, a 1, ..., a n+1 (n <= 3000, -1000 <= a i <=1000). It is known that ai = (ai-1 + ai+1)/2 - ci for each i=1, 2, ..., n.
You are given a 0, a n+1, c 1, ... , c n. Write a program which calculates a 1.

Input

The first line of an input contains an integer n. The next two lines consist of numbers a 0 and a n+1 each having two digits after decimal point, and the next n lines contain numbers c i (also with two digits after decimal point), one number per line.

Output

The output file should contain a 1 in the same format as a 0 and a n+1.

Sample Input

1
50.50
25.50
10.15

Sample Output

27.85

Source

 

 

#include <stdio.h>
int n;
const int S=3050;
double a[S],c[S],anp1;
double fun(){
    int i;
    for (i=2;i<=n+1;i++)
        a[i]=2*a[i-1]-a[i-2]+2*c[i-1];
    return a[n+1];
}
int main(){
    int i;
    double l,r,mid,tmp;
    scanf("%d",&n);
    scanf("%lf %lf",&a[0],&anp1);
    for (i=1;i<=n;i++) scanf("%lf",&c[i]);
    l=-1005;r=1005;
    //        a[1]=27.85;fun();printf("%.2lf  ||||| \n",a[2]);
    while (r-l>1e-4){
        mid=(l+r)/2.0;
        a[1]=mid;
        tmp=fun();
        if (a[n+1]>anp1) {r=mid;}else if ( a[n+1]<anp1 ) {l=mid;} else break;
    }
    printf("%.2lf\n",mid);
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值