数据结构上机测试2-1:单链表操作A

数据结构上机测试2-1:单链表操作A

Time Limit: 1000ms   Memory limit: 4096K  有疑问?点这里^_^

题目描述

输入n个整数,先按照数据输入的顺序建立一个带头结点的单链表,再输入一个数据m,将单链表中的值为m的结点全部删除。分别输出建立的初始单链表和完成删除后的单链表。

输入

第一行输入数据个数n;
第二行依次输入n个整数;
第三行输入欲删除数据m。

输出

第一行输出原始单链表的长度;
第二行依次输出原始单链表的数据;
第三行输出完成删除后的单链表长度;
第四行依次输出完成删除后的单链表数据。

示例输入

10
56 25 12 33 66 54 7 12 33 12
12

示例输出

10
56 25 12 33 66 54 7 12 33 12
7
56 25 33 66 54 7 33


怎么做也做不6的链表
#include <iostream>
#include <stdlib.h>

using namespace std;

int n, m;

struct node
{
    int data;
    struct node * next;
};

struct node * creat()
{
    struct node * head, * tail, * p;
    head = (struct node * )malloc(sizeof(struct node));
    head->next = NULL;
    tail = head;
    for(int i = 0; i < n; i++)
    {
        p = (struct node * )malloc(sizeof(struct node));
        cin >> p->data;
        p->next = NULL;
        tail->next = p;
        tail = p;
    }
    return head;
};

void del(struct node * head)
{
    struct node * p, * q;
    p = head;
    while(p->next != NULL)
    {
        if(p->next->data == m)
        {
            q = p->next;
            p->next = q->next;
            n--;
            free(q);
        }
        else
            p = p->next;
    }
}

void show(struct node * head)
{
    struct node * p;
    p = head->next;
    cout << n << endl;
    while(p->next != NULL)
    {
        cout << p->data << " ";
        p = p->next;
    }
    cout << p->data << endl;
}

int main()
{
    struct node * head;
    cin >> n;
    head = creat();
    cin >> m;
    show(head);
    del(head);
    show(head);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值