3-1 Point类的构造函数

3-1 Point类的构造函数

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description

通过本题目的练习可以掌握类的构造函数的定义;

设计一个点类Point,私有数据成员有xy;公有成员函数有:无参数的构造函数Point(),带参数的构造函数Point(int,int);ShowPoint()输出点对象的信息

在主函数main()中调用相应成员函数,从键盘接收时间对象的xy的值,并向显示器输出相应的值。

Input
 

输入2个整数,用一个空格间隔

Output
 

要求先输出默认的点值,再输出用户构造的点的值

点的格式为:一对圆括号内 x,y的值,中间用“,间隔;

Example Input
10 11
Example Output
(0,0)
(10,11)
Author
#include <iostream>
#include <stdio.h>
using namespace std;

class point
{
    private:
        int x;
        int y;
    public:
        point()
        {
            x = 0;
            y = 0;
        }
        void setpoint();
        void showpoint();
};

void point::setpoint()
{
    cin >> x >> y;
}

void point::showpoint()
{
    cout << "(" << x << "," << y << ")" << endl;
}
int main()
{
    point p1, p2;
    p1.showpoint();
    p2.setpoint();
    p2.showpoint();
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值