poj1180Batch Scheduling【斜率优化dp】

Description

There is a sequence of N jobs to be processed on one machine. The jobs are numbered from 1 to N, so that the sequence is 1,2,..., N. The sequence of jobs must be partitioned into one or more batches, where each batch consists of consecutive jobs in the sequence. The processing starts at time 0. The batches are handled one by one starting from the first batch as follows. If a batch b contains jobs with smaller numbers than batch c, then batch b is handled before batch c. The jobs in a batch are processed successively on the machine. Immediately after all the jobs in a batch are processed, the machine outputs the results of all the jobs in that batch. The output time of a job j is the time when the batch containing j finishes.

A setup time S is needed to set up the machine for each batch. For each job i, we know its cost factor Fi and the time Ti required to process it. If a batch contains the jobs x, x+1,... , x+k, and starts at time t, then the output time of every job in that batch is t + S + (T x + T x+1 + ... + T x+k). Note that the machine outputs the results of all jobs in a batch at the same time. If the output time of job i is Oi, its cost is Oi * Fi. For example, assume that there are 5 jobs, the setup time S = 1, (T1, T2, T3, T4, T5) = (1, 3, 4, 2, 1), and (F1, F2, F3, F4, F5) = (3, 2, 3, 3, 4). If the jobs are partitioned into three batches {1, 2}, {3}, {4, 5}, then the output times (O1, O2, O3, O4, O5) = (5, 5, 10, 14, 14) and the costs of the jobs are (15, 10, 30, 42, 56), respectively. The total cost for a partitioning is the sum of the costs of all jobs. The total cost for the example partitioning above is 153.

You are to write a program which, given the batch setup time and a sequence of jobs with their processing times and cost factors, computes the minimum possible total cost.

Input

Your program reads from standard input. The first line contains the number of jobs N, 1 <= N <= 10000. The second line contains the batch setup time S which is an integer, 0 <= S <= 50. The following N lines contain information about the jobs 1, 2,..., N in that order as follows. First on each of these lines is an integer Ti, 1 <= Ti <= 100, the processing time of the job. Following that, there is an integer Fi, 1 <= Fi <= 100, the cost factor of the job.

Output

Your program writes to standard output. The output contains one line, which contains one integer: the minimum possible total cost.

Sample Input

5
1
1 3
3 2
4 3
2 3
1 4

Sample Output

153

之前斜率优化只做过一个hdu3507Print Article【斜率优化入门题】

结构都是一模一样的,重在推导公式==而且setup意为准备时间不是开始时间QAQ

由于题中给出了cost[i]=(s+(准备时间总和)+(所需时间总和))*(i-j区间的F值),如果正着推导,貌似是无法表示,那我莫不如倒着推导,这样的话dp[i]=min(s+sum[i]-sum[j])*(sumf[i]) 后面那个sumf[j]就不减了,反正早晚要和前面的”i“消掉,然后分子等于dp[j]-dp[k],分母等于sum[j]-sum[k]

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<queue>
using namespace std;
const int MAXN=10010;

int dp[MAXN];
int q[MAXN];//队列
int sum[MAXN],oi[MAXN],fi[MAXN],fsum[MAXN];

int head,tail,n,m;
// dp[i]= min{ dp[j]+M+(sum[i]-sum[j])^2 };
int getDP(int i,int j)
{
    return dp[j]+(sum[i]-sum[j]+m)*(fsum[i]);
}

int getUP(int j,int k) //yj-yk部分
{
    return dp[j]-dp[k];
}
int getDOWN(int j,int  k)
{
    return (sum[j]-sum[k]);
}

int main()
{
   // freopen("cin.txt","r",stdin);
  //  freopen("out.txt","w",stdout);
    while(scanf("%d%d",&n,&m)==2)
    {
        for(int i=1;i<=n;i++)
           scanf("%d%d",&oi[i],&fi[i]);
        sum[n+1]=dp[n+1]=fsum[n+1]=0;
        sum[n]=oi[n];fsum[n]=fi[n];
        for(int i=n-1;i>=1;i--)
          // sum[i]+=sum[i-1];
           sum[i]=sum[i+1]+oi[i],fsum[i]=fsum[i+1]+fi[i];
        head=tail=0;
        q[tail++]=0;
        for(int i=n;i>=1;i--)
        {
            //把斜率转成相乘,注意顺序,否则不等号方向会改变的
            while(head+1<tail &&  getUP(q[head+1],q[head])<=(fsum[i])*getDOWN(q[head+1],q[head]))
               head++;
            dp[i]=getDP(i,q[head]);
            while(head+1<tail && getUP(i,q[tail-1])*getDOWN(q[tail-1],q[tail-2])<=getUP(q[tail-1],q[tail-2])*getDOWN(i,q[tail-1]))
                    tail--;
            q[tail++]=i;
        }
        printf("%d\n",dp[1]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值