#poj1180#Batch Scheduling (经典逆推Dp+斜率优化)

Batch Scheduling
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4068 Accepted: 1860


Description

There is a sequence of N jobs to be processed on one machine. The jobs are numbered from 1 to N, so that the sequence is 1,2,..., N. The sequence of jobs must be partitioned into one or more batches, where each batch consists of consecutive jobs in the sequence. The processing starts at time 0. The batches are handled one by one starting from the first batch as follows. If a batch b contains jobs with smaller numbers than batch c, then batch b is handled before batch c. The jobs in a batch are processed successively on the machine. Immediately after all the jobs in a batch are processed, the machine outputs the results of all the jobs in that batch. The output time of a job j is the time when the batch containing j finishes. 

A setup time S is needed to set up the machine for each batch. For each job i, we know its cost factor Fi and the time Ti required to process it. If a batch contains the jobs x, x+1,... , x+k, and starts at time t, then the output time of every job in that batch is t + S + (T x + T x+1 + ... + T x+k). Note that the machine outputs the results of all jobs in a batch at the same time. If the output time of job i is Oi, its cost is Oi * Fi. For example, assume that there are 5 jobs, the setup time S = 1, (T1, T2, T3, T4, T5) = (1, 3, 4, 2, 1), and (F1, F2, F3, F4, F5) = (3, 2, 3, 3, 4). If the jobs are partitioned into three batches {1, 2}, {3}, {4, 5}, then the output times (O1, O2, O3, O4, O5) = (5, 5, 10, 14, 14) and the costs of the jobs are (15, 10, 30, 42, 56), respectively. The total cost for a partitioning is the sum of the costs of all jobs. The total cost for the example partitioning above is 153. 

You are to write a program which, given the batch setup time and a sequence of jobs with their processing times and cost factors, computes the minimum possible total cost. 

Input

Your program reads from standard input. The first line contains the number of jobs N, 1 <= N <= 10000. The second line contains the batch setup time S which is an integer, 0 <= S <= 50. The following N lines contain information about the jobs 1, 2,..., N in that order as follows. First on each of these lines is an integer Ti, 1 <= Ti <= 100, the processing time of the job. Following that, there is an integer Fi, 1 <= Fi <= 100, the cost factor of the job.

Output

Your program writes to standard output. The output contains one line, which contains one integer: the minimum possible total cost.

Sample Input

5
1
1 3
3 2
4 3
2 3
1 4

Sample Output

153


其实如果直接写DP的话,是相当好写的,定义Dp[i]表示从1到i的花费,

但是这样写出来的Dp并不能用斜率优化来做,或许还有其他办法,但是我不会了。

试过正推失败之后,就开始观察题目,会发现时间是一直都在向后推的,

然后就会想到,如果定义Dp[i]表示N到i,就可以减少一个括号中的两个乘积,

然后就是斜率优化了。

Dp[i] = min(Dp[j] + (S + smt[i] - smt[j]) * smc[i])

Code:

Status Accepted
Memory 780kB
Length 1123
Lang G++
Submitted
Shared
RemoteRunId 17066070

#include<iostream>
#include<cstdio>
#include<cstdlib>
using namespace std;

const int Max = 10005;

int N, S;

int smc[Max], smt[Max], Q[Max], Dp[Max];

void getint(int & num){
    char c;	int flag = 1;	num = 0;
    while((c = getchar()) < '0' || c > '9')	if(c == '-')	flag = -1;
    while(c >= '0' && c <= '9'){num = num * 10 + c - 48;	c = getchar();}
    num *= flag;
}

int get_Dp(int i, int j){	return Dp[j] + (S + smt[i] - smt[j]) * smc[i];}
int nume(int a, int b){	return Dp[a] - Dp[b];}
int deno(int a, int b){	return smt[a] - smt[b];}

int main(){
	while(~scanf("%d%d", &N, &S)){
		smt[N + 1] = smc[N + 1] = 0;
		for(int i = 1; i <= N; ++ i)
			getint(smt[i]), getint(smc[i]);
		for(int i = N; i; -- i)
			smt[i] += smt[i + 1],
			smc[i] += smc[i + 1];
		int fro = 1, back = 0;
		Q[++ back] = 0;
		for(int i = N; i; -- i){
			while(fro < back && nume(Q[fro + 1], Q[fro]) <= smc[i] * deno(Q[fro + 1], Q[fro]))
				++ fro;
			Dp[i] = get_Dp(i, Q[fro]);
			while(fro < back && nume(i, Q[back]) * deno(Q[back], Q[back - 1]) <= nume(Q[back], Q[back - 1]) * deno(i, Q[back]))
				-- back;
			Q[++ back] = i;
		}
		printf("%d\n", Dp[1]);
	}
	return 0;
}









  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值