题目1510:替换空格-九度

题目描述:
请实现一个函数,将一个字符串中的空格替换成“%20”。例如,当字符串为We Are Happy.则经过替换之后的字符串为We%20Are%20Happy。
输入:
每个输入文件仅包含一组测试样例。
对于每组测试案例,输入一行代表要处理的字符串。
输出:
对应每个测试案例,出经过处理后的字符串。
样例输入:
We Are Happy
样例输出:

We%20Are%20Happy

推荐指数:※

来源:http://ac.jobdu.com/problem.php?pid=1510

这也是海涛的《剑指offer》的题目。

#include<iostream>
#include<string>
#include<sstream>
#include<string.h>
#include<stdio.h>
using namespace std;
int main()
{
	char ch;
	while((ch=getchar())!='\n'){
		if(ch!=' ')
			printf("%c",ch);
		else
			printf("%%20");
	}
    return 0;
}
本来写了个用stringstream,但在getline的时候,两次回车不太好处理(解决方法: http://support.microsoft.com/default.aspx?scid=KB;EN-US;q240015&ID=KB;EN-US;q240015),木有AC(重写getline函数?)。

#include<iostream>
#include<string>
#include<sstream>
#include<string.h>
#include<stdio.h>
using namespace std;
int main()
{
    string str,strout;
    getline(cin,str);//need to enter
    stringstream streamstr;
	streamstr<<str;
    int flag=0;
    while(streamstr>>strout){
        if(flag!=0)
            cout<<"%20"<<strout;
        else{
            cout<<strout;
			flag=1;
		}
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值