Stacks of Flapjacks 翻煎饼-UVA120 白书第五章



 Stacks of Flapjacks 

Background

Stacks and Queues are often considered the bread and butter of data structures and find use in architecture, parsing, operating systems, and discrete event simulation. Stacks are also important in the theory of formal languages.

This problem involves both butter and sustenance in the form of pancakes rather than bread in addition to a finicky server who flips pancakes according to a unique, but complete set of rules.

The Problem

Given a stack of pancakes, you are to write a program that indicates how the stack can be sorted so that the largest pancake is on the bottom and the smallest pancake is on the top. The size of a pancake is given by the pancake's diameter. All pancakes in a stack have different diameters.

Sorting a stack is done by a sequence of pancake ``flips''. A flip consists of inserting a spatula between two pancakes in a stack and flipping (reversing) the pancakes on the spatula (reversing the sub-stack). A flip is specified by giving the position of the pancake on the bottom of the sub-stack to be flipped (relative to the whole stack). The pancake on the bottom of the whole stack has position 1 and the pancake on the top of a stack of n pancakes has position n.

A stack is specified by giving the diameter of each pancake in the stack in the order in which the pancakes appear.

For example, consider the three stacks of pancakes below (in which pancake 8 is the top-most pancake of the left stack):

         8           7           2
         4           6           5
         6           4           8
         7           8           4
         5           5           6
         2           2           7
The stack on the left can be transformed to the stack in the middle via  flip(3) . The middle stack can be transformed into the right stack via the command  flip(1) .

The Input

The input consists of a sequence of stacks of pancakes. Each stack will consist of between 1 and 30 pancakes and each pancake will have an integer diameter between 1 and 100. The input is terminated by end-of-file. Each stack is given as a single line of input with the top pancake on a stack appearing first on a line, the bottom pancake appearing last, and all pancakes separated by a space.

The Output

For each stack of pancakes, the output should echo the original stack on one line, followed by some sequence of flips that results in the stack of pancakes being sorted so that the largest diameter pancake is on the bottom and the smallest on top. For each stack the sequence of flips should be terminated by a 0 (indicating no more flips necessary). Once a stack is sorted, no more flips should be made.

Sample Input

1 2 3 4 5
5 4 3 2 1
5 1 2 3 4

Sample Output

1 2 3 4 5
0
5 4 3 2 1
1 0
5 1 2 3 4
1 2 0

思路:先检查这些煎饼是否顺序排好,如果没有排好的话,找出当前位置下的最大的煎饼,翻转它使他翻到最上面,再从下面翻转一次,可以使他落到正确位置。。

#include<iostream>
#include<algorithm>
#include<string>
#include<cstring>

using namespace std;

int cake[40];

bool is_sort(int *arry,int len)
{
    int i;
    for(i=2;i<=len;i++)
    {
        if(arry[i]<arry[i-1])
            return false;
    }
    return true;
}

int max_c(int *arry,int len)
{
    int i,j=1,max=0;
    for(i=1;i<=len;i++)
    {
        if(arry[i]>max)
        {
            max=arry[i];
            j=i;
        }
    }
    return j;
}

void rev(int *arry,int len1,int t)
{
    int i;
    for(i=1;i<t/2+1;i++)
    {
        swap(arry[i],arry[t-i+1]);
    }
}

int main()
{
    string str;
    while(getline(cin,str))
    {
        memset(cake,0,sizeof(cake));
        int r=0,k=0,i;
        for(i=0;i<str.size();i++)
        {
            if(str[i]!=' ')
            {
                if(i==(str.size()-1))
                {
                    cake[++k]=r*10+str[i]-'0';
                }
                else
                {
                    r=r*10+str[i]-'0';
                }
            }
            else
            {
                cake[++k]=r;
                r=0;
            }
        }
        cout<<str<<endl;
         int len=k;
        while(!is_sort(cake,len))
        {
            i=max_c(cake,k);
            if(i==k)
            {
                k--;
                continue;
            }
            if(i!=1)
            {
                rev(cake,len,i);
                cout<<len-i+1<<" ";
            }
            cout<<len-k+1<<" ";
            rev(cake,len,k);
            k--;
        }
        cout<<"0"<<endl;
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值