[贪心]UVA11054 Wine trading in Gergovia

2006/2007 ACM International Collegiate Programming Contest 
University of Ulm Local Contest

Wine trading in Gergovia

As you may know from the comic "Asterix and the Chieftain's Shield", Gergovia consists of one street, and every inhabitant of the city is a wine salesman. You wonder how this economy works? Simple enough: everyone buys wine from other inhabitants of the city. Every day each inhabitant decides how much wine he wants to buy or sell. Interestingly, demand and supply is always the same, so that each inhabitant gets what he wants.

There is one problem, however: Transporting wine from one house to another results in work. Since all wines are equally good, the inhabitants of Gergovia don't care which persons they are doing trade with, they are only interested in selling or buying a specific amount of wine. They are clever enough to figure out a way of trading so that the overall amount of work needed for transports is minimized.

In this problem you are asked to reconstruct the trading during one day in Gergovia. For simplicity we will assume that the houses are built along a straight line with equal distance between adjacent houses. Transporting one bottle of wine from one house to an adjacent house results in one unit of work.

Input Specification

The input consists of several test cases. Each test case starts with the number of inhabitants n (2 ≤ n ≤ 100000). The following line contains n integers ai (-1000 ≤ ai ≤ 1000). If ai ≥ 0, it means that the inhabitant living in the ith house wants to buy ai bottles of wine, otherwise if ai < 0, he wants to sell -ai bottles of wine. You may assume that the numbers ai sum up to 0.
The last test case is followed by a line containing 0.

Output Specification
For each test case print the minimum amount of work units needed so that every inhabitant has his demand fulfilled. You may assume that this number fits into a signed 64-bit integer (in C/C++ you can use the data type "long long", in JAVA the data type "long").
Sample Input
5
5 -4 1 -3 1
6
-1000 -1000 -1000 1000 1000 1000
0
Sample Output
9
9000

题意:题意:一题街道上很多酒店,交易葡萄酒,正数为卖出葡萄酒,负数为需要葡萄酒,总需求量和总售出量是相等的,从一家店到另外一家店需要路费(路费=距离×运算量),假设每家店线性排列且相邻两店之间距离都是1,求最小路费。

思路:一开始看出是贪心但是方法完全用错,我的想法是按照出售或者买进的葡萄酒的数量排序,然后依次向右找到要买进或者要卖出的居民,直到所有的都为零,时间复杂度应该是O(N*LogN),但是果断超时了。。后来参考别人的思路,算是明白怎么一回事了。

我们可以假想第i个人总是与第i+1个人来进行交易来满足i的要求,这样每个人就都是与其最近的人进行交易,从而产生了最优解。

代码:

#include<iostream>
#include<cmath>

using namespace std;

int val[100005];

int main()
{
	int n;
	while(cin>>n&&n)
		{
			int i;
			long long sum=0;
			for(i=0;i<n;i++)
				{
					cin>>val[i];
				}
			for(i=0;i<n;i++)
				{
					sum=sum+abs(val[i]);
					val[i+1]=val[i]+val[i+1];
				}
			cout<<sum<<endl;
		}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值