Android Call requires API level 11 (current min is 8)的解决方案

转载 2013年12月04日 16:19:26


【错误描述】

    在用Eclipse开发过程中,为了兼容Android2.2和4.0以上版本,我在使用Notification类时做了2个版本的代码,代码根据系统版本不同执行相应模块,结果,等我输完代码,发现系统提示了一个这么的错误。

【原因分析】

    不详,可能和Run Android Lint有点关系吧。就是创建项目时,我们设置了最低版本API Level,比如我的是8,因此,Eclipse检查我调用的API后,发现版本号不能向低版本兼容,比如我用的“Notification.Builder”是Level 11 以上才有的,自然超过了8,所以提示错误。

【解决方案】

   右键点击项目->Android tools ->Clear Link Markers.即可临时解决,但是如果调试用的模拟器是低版本的,则在调试完后还有这个错误。

  如果把manifest文件中的user-sdk的android:minSdkVersion改为报错的那个高版本就没事。比如下面:

<uses-sdk

        android:minSdkVersion="11"   //这个之前是8

        android:targetSdkVersion="17" />


  

【扩展】

  这种错误不仅发生在Level11,也同时发生于其他因为设置了最低版本,但使用了高版本API的代码中,解决方案应该相同。

相关文章推荐

Android Call requires API level 11 (current min is 8)的解决方案

*【错误描述】 -在用Eclipse开发过程中,为了兼容Android2.2和4.0以上版本,我在使用Notification类时做了2个版本的代码, 代码根据系统版本不同执行相应模块,结果,等我输完...

Call requires API level 11 (current min is 8)

【错误描述】在用Eclipse开发过程中,为了兼容Android2.2和4.0以上版本,我在使用Notification类时做了2个版本的代码,代码根据系统版本不同执行相应模块,结果,等我输完代码,发...

【PB】DBMS is not supported in your current installation解决方案

第一种情况: 如果单击PB环境中的db profile工具栏按钮,然后选择相应的接口,最后单击“new...”按钮时出现如图提示时 解决方法: 我们在使用PowerBuilder的直联接口(na...

slf4j-api 1.6.x (or later) is incompatible with this binding.解决方案及原理

前几天搭建工程的时候,每次启动总会报这个异常: SLF4J: slf4j-api 1.6.x (or later) is incompatible with this binding. SLF4...

Android requires compiler compliance level 5.0 or 6.0. 出错原因分析、解决方法

开发过程中碰到了一个问题:  Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please u...

UncaughtException 和 Using 1.7 requires compiling with Android 4.4 (KitKat); currently using API 8

08-04 10:54:04.545: W/dalvikvm(10012): threadid=1: calling UncaughtExceptionHandler 08-04 10:54:04.5...

精通CSS[高级Web标准解决方案][8/11]

  • 2008年08月28日 17:13
  • 4.29MB
  • 下载

"<item> tag requires a 'drawable' attribute"-selector设置颜色不成功-解决方案

设置方法: Button中引用android:background="@drawable/button_background_selector" 在文件夹drawable下定义button_back...

Eclipse Maven 编译错误 Dynamic Web Module 3.0 requires Java 1.6 or newer 解决方案

Eclipse Maven 开发一个 jee 项目时,编译时遇到以下错误:Description Resource Path Location TypeDynamic Web Module 3.0 r...
  • defonds
  • defonds
  • 2015年08月25日 11:17
  • 40575

"Edit Document" requires a Microsoft SharePoint Foundation-compatible Application错误的解决方案

今天在SharePoint2016环境下Document Library修改Default template为ODT file时遇到错误"Edit Document" requires a Micro...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:Android Call requires API level 11 (current min is 8)的解决方案
举报原因:
原因补充:

(最多只允许输入30个字)