UVA 11375

11375 - Matches

Time limit: 2.000 seconds

Problem E: Matches

We can make digits with matches as shown below:

Given N matches, find the number of different numbers representable using the matches. We shall only make numbers greater than or equal to 0, so no negative signs should be used. For instance, if you have 3 matches, then you can only make the numbers 1 or 7. If you have 4 matches, then you can make the numbers 1, 4, 7 or 11. Note that leading zeros are not allowed (e.g. 001, 042, etc. are illegal). Numbers such as 0, 20, 101 etc. are permitted, though.

Input

Input contains no more than 100 lines. Each line contains one integer N (1 ≤ N ≤ 2000).

Output

For each N, output the number of different (non-negative) numbers representable if you have N matches.

Sample Input

3
4

Sample Output

2
4


Problemsetter: Mak Yan Kei
本题是递推,给你n根火柴问你能组成多少个非负整数。用c数组记录每个数字需要的火柴数。dp记录用i根火柴可以组成的正整数。dp数组可递推出。注意n >=6时要加一,代表整数0.

import java.math.BigInteger;
import java.util.Scanner;

public class Main{
    public static void main(String[] args){
	final BigInteger ONE = new BigInteger("1");
	final int[] c = {6 , 2 , 5 , 5 , 4 , 5 , 6 , 3 , 7 , 6};
	final int N = 2150;
	BigInteger dp[] = new BigInteger[N];
	for(int i = 1 ; i < N ; i++)dp[i] = new BigInteger("0");
	dp[0] = ONE;
	for(int i = 0 ; i <= 2100 ; i++)
	{
		for(int j = 0 ; j < 10 ; j++)
		{
	     if(!(i == 0&&j == 0) )dp[i + c[j]] = dp[i + c[j]].add(dp[i]);
		}
		if(i > 0)dp[i] = dp[i].add(dp[i - 1]);
	}
	for(int i = 0 ; i < 6 ; i++)
	{
		dp[i] = dp[i].subtract(ONE);
	}
	Scanner cin = new Scanner(System.in);
	while(cin.hasNext()){
		int n = cin.nextInt();
		System.out.println(dp[n]);
	}
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值