Superprime Rib
Butchering Farmer John's cows always yields the best prime rib. You can tell prime ribs by looking at the digits lovingly stamped across them, one by one, by FJ and the USDA. Farmer John ensures that a purchaser of his prime ribs gets really prime ribs because when sliced from the right, the numbers on the ribs continue to stay prime right down to the last rib, e.g.:
7 3 3 1
The set of ribs denoted by 7331 is prime; the three ribs 733 are prime; the two ribs 73 are prime, and, of course, the last rib, 7, is prime. The number 7331 is called a superprime of length 4.
Write a program that accepts a number N 1 <=N<=8 of ribs and prints all the superprimes of that length.
The number 1 (by itself) is not a prime number.
PROGRAM NAME: sprime
INPUT FORMAT
A single line with the number N.SAMPLE INPUT (file sprime.in)
4
OUTPUT FORMAT
The superprime ribs of length N, printed in ascending order one per line.SAMPLE OUTPUT (file sprime.out)
2333 2339 2393 2399 2939 3119 3137 3733 3739 3793 3797 5939 7193 7331 7333 7393
我们可以发现一个规律就是n等于1时只能是2,3,5,7,n>1时每一位都是1,3,7,9之一,那么我们直接暴枚即可,这题正解应该是DFS去搜每一位的数字。
/*
ID: xinming2
PROG: sprime
LANG: C++
*/
#include <cstdlib>
#include <cctype>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <vector>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <fstream>
#include <numeric>
#include <iomanip>
#include <bitset>
#include <list>
#include <stdexcept>
#include <functional>
#include <utility>
#include <ctime>
using namespace std;
#define PB push_back
#define MP make_pair
#define REP(i,n) for(i=0;i<(n);++i)
#define FOR(i,l,h) for(i=(l);i<=(h);++i)
#define FORD(i,h,l) for(i=(h);i>=(l);--i)
typedef vector<int> VI;
typedef vector<string> VS;
typedef vector<double> VD;
typedef long long LL;
typedef pair<int,int> PII;
int q[10000] = {2 , 3 , 5, 7};
bool isprime(int x)
{
if(x == 0 || x == 1)return 0;
else for(int i = 3 ; i * i <= x ; i += 2)
{
if(x % i == 0)return 0;
}
return 1;
}
int main()
{
freopen("sprime.in" , "r" , stdin);
freopen("sprime.out" , "w" , stdout);
int n;
while(~scanf("%d", &n))
{
int maxnum = pow(10.0 , n);
int minnum = maxnum / 10;
int front = 0 , rear = 4;
while(front < rear)
{
int k = q[front++];
if(isprime(k * 10 + 1))q[rear++] = k * 10 + 1;
if(isprime(k * 10 + 3))q[rear++] = k * 10 + 3;
if(isprime(k * 10 + 7))q[rear++] = k * 10 + 7;
if(isprime(k * 10 + 9))q[rear++] = k * 10 + 9;
if(q[rear - 1] > maxnum)break;
}
for(int i = 0 ; q[i] < maxnum ; i++)
{
if(q[i] >= minnum)cout << q[i] << endl;
}
}
return 0;
}