HDU 1022 火车进出站问题

博客探讨了如何处理有N辆火车的进出站顺序问题,重点在于判断火车能否按照特定序列2的方式出站。文章提供了作者的C++代码实现。
摘要由CSDN通过智能技术生成
Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
 

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 

Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 

Sample Input
  
  
3 123 321 3 123 312
 

Sample Output
  
  
Yes. in in in out out out FINISH No. FINISH
Hint
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".

题目大概意思:有N辆火车,以序列1方式进站,判断是否能以序列2方式出栈。进站不一定是一次性进入,也就是说中途可以出站。

我的代码:

#include <iostream>
#include <cstring>
using namespace std;
char a[5000000],O1[5000000],O2[5000000];
int cnt[5000000];
int main()
{
	int n,top,i,j,k;
	while (cin >> n >> O1 >> O2)
	{
		top=-1;
		j=0;
		k=-1;
		for (i=0;O1[i]!='\0';++i)
		{
			a[++top]=O1[i];
			cnt[++k]=1;
			while (a[top]==O2[j]&&top!=-1)
			{
				top--;
				j++;
				cnt[++k]=2;
			}
		}
		if (top==-1)
		{
			cout << "Yes." << endl;
			for (i=0;i<=k;++i)
			{
				if (cnt[i]==1)
				{
					cout << "in" << endl;
				}
				else
				{
					cout << "out" << endl;
				}
			}
		}
		else
		{
			cout << "No." << endl;
		}
		cout << "FINISH" << endl;
	}
	return 0;
}

网上代码:


#include<iostream>
#include<stack>
#define max 100
using namespace std;
int main()
{
    stack<char>s;
    int n,i,j,k,result[max];//n为列车个数, result数组用来表示结果,1表示进栈。0表示出
    char str1[max],str2[max];//序列1和序列2
    while(cin>>n>>str1>>str2)
    {
        j=0,i=0,k=1;
        s.push(str1[0]);//为防止栈空,压一个进去
        result[0]=1;//记录进来了一个。
        while(i<n&&j<n)
        {
            if(s.size()&&s.top()==str2[j])
            {//如果栈顶元素与序列2当前的元素相等,则弹栈,序列2集团向后移一位。
                j++;
                s.pop();
                result[k++]=0;
            }
            else
            {//否则从序列1中取当前元素压入栈中。
                if(i==n)break;
                s.push(str1[++i]);
                result[k++]=1;
            }
        }
        if(i==n)//如果I==N表示栈顶元素不等于序列2当前元素,且序列1中元素都已经入过栈,判断不能得到序列2一样的答案。
            cout<<"No."<<endl;
        else
        {//输出进出栈方式
            cout<<"Yes."<<endl;
            for(i=0; i<k; i++)
                if(result[i])
                    cout<<"in"<<endl;
                else
                    cout<<"out"<<endl;
        }
        cout<<"FINISH"<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值