POJ 2718 - Smallest Difference(双DFS)

D - Smallest Difference
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

Given a number of distinct decimal digits, you can form one integer by choosing a non-empty subset of these digits and writing them in some order. The remaining digits can be written down in some order to form a second integer. Unless the resulting integer is 0, the integer may not start with the digit 0. 

For example, if you are given the digits 0, 1, 2, 4, 6 and 7, you can write the pair of integers 10 and 2467. Of course, there are many ways to form such pairs of integers: 210 and 764, 204 and 176, etc. The absolute value of the difference between the integers in the last pair is 28, and it turns out that no other pair formed by the rules above can achieve a smaller difference.

Input

The first line of input contains the number of cases to follow. For each case, there is one line of input containing at least two but no more than 10 decimal digits. (The decimal digits are 0, 1, ..., 9.) No digit appears more than once in one line of the input. The digits will appear in increasing order, separated by exactly one blank space.

Output

For each test case, write on a single line the smallest absolute difference of two integers that can be written from the given digits as described by the rules above.

Sample Input

1
0 1 2 4 6 7

Sample Output

28
 
   
题意:
  给你一些数,然后要求你使用这些数字组成2个数,然后求他们的差值最小。
 
   
/*
这题我一直超时,这种Ac的方法我是想到了,分开两边做,结果我就是没想到
下面的在dfs里再加个全排列。写了个保存全部数据再去一个个分析。。。还是
对于数据上的处理有点弱,想到做法,就是写不出来。
*/


#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdio>
#include<cmath>
#include<ctime>
#include<cstdlib>
#include<queue>
#include<vector>
using namespace std;
#define T 500
#define inf 0x3f3f3f3fL
typedef long long ll;

int Abs(int a,int b)
{
	return a>b?a-b:b-a;
}

int a[15],b[15];
bool vis[15];
int k,mi;

void slove(int val)
{	
	int cnt = 0,ans=0;
	for(int i=0;i<k;++i){
		if(!vis[i]){
			b[cnt++] = a[i];
		}
	}
	do
	{
		ans = 0;
		if(b[0]!=0||cnt==1){
			for(int i=0;i<cnt;++i){
			
				ans = ans*10 + b[i];
			}
			mi = min(Abs(val,ans),mi);
		}
	}while(next_permutation(b,b+cnt));
}

void dfs(int c,int val)
{
	if(c==k/2){
		slove(val);
		return;
	}
	for(int i=0;i<k;++i){
		if(!vis[i]){
			if(c==0&&a[i]==0)continue;
			vis[i] = true;
			dfs(c+1,val*10+a[i]);
			vis[i] = false;
		}
	}
}



int main()
{
#ifdef zsc
	freopen("input.txt","r",stdin);
#endif

	int n,i,j;
	scanf("%d",&n);
	getchar();
	while(n--)
	{
		char s;
		k=0;
		bool bo[15]={false};
		while(cin.get(s))
		{
			if(s=='\n')break;
			if(s>='0'&&s<='9'){
				a[k++] = s-'0';
				bo[s-'0'] = true;
			}
		}
		mi = inf;
		memset(vis,false,sizeof(vis));
		dfs(0,0);
		printf("%d\n",mi);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值