HDU:2120 Ice_cream's world I(并查集+统计环的个数)

6 篇文章 0 订阅
3 篇文章 0 订阅

Ice_cream's world I

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1277    Accepted Submission(s): 763


Problem Description
ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
 

Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
 

Output
Output the maximum number of ACMers who will be awarded.
One answer one line.
 

Sample Input
  
  
8 10 0 1 1 2 1 3 2 4 3 4 0 5 5 6 6 7 3 6 4 7
 

Sample Output
  
  
3
 

Author
Wiskey
 

Source
 

Recommend
威士忌


题目大意:给你n,k代表0~n-1号点,k条边,接下来k行。问这个图能成几个环。
解题思路:当合并两个新的元素时,如果两个元素同根,那么合并后必成一个环。
#include <cstdio>
#include <cstring>
int pre[1010];
int find(int x)
{
	int r=x;
	while(r!=pre[r])
	{
		r=pre[r];
	}
	int i=x,j;
	while(i!=r)//压缩优化下 
	{
		j=pre[i];
		pre[i]=r;
		i=j;
	}
	return r;
}
int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		memset(pre,-1,sizeof(pre));//初始化-1,-1用不着 ,这样初始化好像后面也没怎么用到 
		int cnt=0;//统计环的个数 
		for(int i=0;i<m;i++)
		{
			int x,y;
			scanf("%d%d",&x,&y);
			if(pre[x]==-1)
			{
				pre[x]=x;
			}
			if(pre[y]==-1)
			{
				pre[y]=y;
			}
			int fx=find(x);
			int fy=find(y);
			if(fx==fy)//同根的话,那么必成环 
			{
				cnt++;
			}
			pre[fx]=fy;
		}
		printf("%d\n",cnt);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值