HDU:2196 Computer(树的最大直径+巧妙打表)

11 篇文章 0 订阅
7 篇文章 0 订阅

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5677    Accepted Submission(s): 2837


Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information. 


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
  
  
5 1 1 2 1 3 1 1 1
 

Sample Output
  
  
3 2 3 4 4
 

Author
scnu
 

Recommend
lcy
题目大意:求每个点所能到达的最远距离。
解题思路:用bfs求最远路径一个一个求的话会超时,不妨先随意找个点,然后扫到它能到达最远的点s,以s为起点,找它最远的点t,在找t的过程中用d1数组记录s到每点的步数,找到t后,再用t扫s,扫的过程中用d2数组记录下t到每点的距离,那么每点所能到达的最远距离要么的d1,要么是d2,比较输出即可。
代码如下:
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
int n,num;
struct node
{
	int from,to,val,last;
}bian[20010];
int head[10010];
int vis[10010];
int dis[10010];
int d1[10010];
int d2[10010];
int start;
int ans;
void add(int s,int e,int power)
{
	bian[num].from=s;
	bian[num].to=e;
	bian[num].val=power;
	bian[num].last=head[s];
	head[s]=num;
	num++;
}
void dfs(int x)
{
	int r=x;
	queue<int>q;
	q.push(r);
	vis[r]=1;
	dis[r]=0;
	ans=0;
	while(!q.empty())
	{
		int tmp1=q.front();
		q.pop();
		for(int i=head[tmp1];i!=-1;i=bian[i].last)
		{
			int tmp2=bian[i].to;
			if(vis[tmp2]==0&&dis[tmp2]<dis[tmp1]+bian[i].val)
			{
				dis[tmp2]=dis[tmp1]+bian[i].val;
				if(dis[tmp2]>ans)
				{
					start=tmp2;
					ans=dis[tmp2];
				}
				vis[tmp2]=1;
				q.push(tmp2);
			}
		}
	}
}
void dfss(int x)
{
	int r=x;
	queue<int>q;
	q.push(r);
	vis[r]=1;
	d1[r]=0;
	ans=0;
	while(!q.empty())
	{
		int tmp1=q.front();
		q.pop();
		for(int i=head[tmp1];i!=-1;i=bian[i].last)
		{
			int tmp2=bian[i].to;
			if(vis[tmp2]==0&&d1[tmp2]<d1[tmp1]+bian[i].val)
			{
				d1[tmp2]=d1[tmp1]+bian[i].val;
				if(d1[tmp2]>ans)
				{
					ans=d1[tmp2];
					start=tmp2;
				}
				vis[tmp2]=1;
				q.push(tmp2);
			}
		}
	}
}
void dfst(int x)
{
	int r=x;
	queue<int>q;
	q.push(r);
	vis[r]=1;
	d2[r]=0;
	ans=0;
	while(!q.empty())
	{
		int tmp1=q.front();
		q.pop();
		for(int i=head[tmp1];i!=-1;i=bian[i].last)
		{
			int tmp2=bian[i].to;
			if(vis[tmp2]==0&&d2[tmp2]<d2[tmp1]+bian[i].val)
			{
				d2[tmp2]=d2[tmp1]+bian[i].val;
				vis[tmp2]=1;
				q.push(tmp2);
			}
		}
	}
}
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		num=0;
		memset(head,-1,sizeof(head));
		for(int i=2;i<=n;i++)
		{
			int j,p;
			scanf("%d%d",&j,&p);
			add(i,j,p);
			add(j,i,p);
		}
		memset(vis,0,sizeof(vis));
		memset(dis,0,sizeof(dis));
		dfs(1);//随意搜个点,找到s 
		memset(vis,0,sizeof(vis));
		memset(d1,0,sizeof(d1));
		dfss(start);//s扫t,顺便打表 
		memset(vis,0,sizeof(vis));
		memset(d2,0,sizeof(d2));
		dfst(start);//t扫s,顺便打表 
		for(int i=1;i<=n;i++)
		{
			printf("%d\n",max(d1[i],d2[i]));
		}
	}
	return 0;
}


 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值