UVA - 442 Matrix Chain Multiplication

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices.Since matrix multiplication is associative, the order in which multiplications are performed isarbitrary. However, the number of elementary multiplications needed strongly depends on theevaluation order you choose.

For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix.There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).

The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed fora given evaluation strategy.

Input Specification

Input consists of two parts: a list of matrices and a list of expressions.

The first line of the input file contains one integer n ( tex2html_wrap_inline28 ), representing the number ofmatrices in the first part. The next n lines each contain one capital letter, specifying the name of thematrix, and two integers, specifying the number of rows and columns of the matrix.

The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

Output Specification

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125



题意:
输入n个矩阵的维度和一些矩阵链乘表达式,输出乘法的次数。若矩阵可以进行相乘假设A*B,则A的列要等于B的列
假定A和m*n的,B是n*p的,那么AB是m*p的,乘法次数为m*n*p 
算法:用一个栈。遇到字母时入栈,再遇到“)”时,将字母出栈(只会有两个字母)并计算,最后再把结果入栈。
#include<iostream>
#include<stack>
#include<cstdio>
#include<cctype>
#include<cstring>
#include<algorithm>
using namespace std;
class M
{
	public:
		int h;
		int l;
		M(int a = 0,int b = 0)
		{
			h = a;
			l = b;
		}


};
M m[26];
stack<M> s;
int main(){

	int n;
	scanf("%d",&n); getchar();
	while(n --)
	{
		string str;
		cin >> str;
		int k = str[0] - 'A';
		cin >> m[k].h >> m[k].l;
	
	}

	string str1;
	while(cin >> str1)
	{	int flag = 1;
		int len = str1.length();
		int sum = 0;
		for(int i = 0; i <len ; i ++)
		{
			if(isalpha(str1[i]))
				s.push(m[str1[i] - 'A']);
			else if(str1[i] == ')')
			{
				M m2 = s.top();
				s.pop();
				M m1 = s.top();
				s.pop();
			
			if(m1.l != m2.h){
				flag = 0;
				printf("error\n");
				break;
			}
				sum += m1.h * m1.l *m2.l;
			s.push( M (m1.h , m2.l));
			}			
		
		}
	if(flag)
	printf("%d\n",sum);
	}
return  0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值