UVA - 193 Graph Coloring


 Graph Coloring 

You are to write a program that tries to find an optimal coloring for a given graph. Colors are applied to the nodes of the graph and the only available colors are black and white. The coloring of the graph is called optimal if a maximum of nodes is black. The coloring is restricted by the rule that no two connected nodes may be black.

 figure22
Figure: An optimal graph with three black nodes

Input and Output

The graph is given as a set of nodes denoted by numbers tex2html_wrap_inline33 , tex2html_wrap_inline35 , and a set of undirected edges denoted by pairs of node numbers tex2html_wrap_inline37 , tex2html_wrap_inline39 . The input file contains m graphs. The number m is given on the first line. The first line of each graph contains n and k, the number of nodes and the number of edges, respectively. The followingk lines contain the edges given by a pair of node numbers, which are separated by a space.

The output should consists of 2m lines, two lines for each graph found in the input file. The first line of should contain the maximum number of nodes that can be colored black in the graph. The second line should contain one possible optimal coloring. It is given by the list of black nodes, separated by a blank.

Sample Input

1
6 8
1 2
1 3
2 4
2 5
3 4
3 6
4 6
5 6

Sample Output

3
1 4 5
 
题意:
找出最大的黑色,利用回溯来做;
 
#include <iostream>
#include <cstdio>
#include <cstring>
#define N 105
using namespace std;

int T, n, m;
int endge[N][N];
int u,v;
int black[N],ant[N],ans[N];
int k,Max;

int judge(int cur) {
	for (int i = 1; i <= n; i++) {
		if (endge[cur][i] && black[i])
			return 0;		
	}
	return 1;
}

void dfs(int cur) {
	if (cur == n +1) {  //记得是n+1
		k = 0;
		for (int i = 1; i <= n; i++) {
			if (black[i]){
				ant[k++] = i;
			}
		}
		if (Max < k) {
			for (int i = 0; i < k; i++)
				ans[i] = ant[i];
			Max = k;	
		}	
		return ;
	}

//判断与当前cur相连的点是不是黑色,如果return 1 ,表示相连的都是白色;
		if (judge(cur)) {	
			black[cur] = 1; //相连的点都是白色,标志为黑色
			dfs(cur+1);
			black[cur] = 0;
		}
	
     dfs(cur+1); //不能被染色为黑色,只能递归寻找白色
}
int main () {
	scanf("%d",&T);
	while (T--) {
		scanf("%d%d",&n,&m);
		memset(endge,0,sizeof(endge));
		memset(black,0,sizeof(black));
		for (int i = 0; i < m; i++) {
			scanf("%d%d",&u,&v);
			endge[u][v]=1;
			endge[v][u]=1;
		}
		Max = -1;
		dfs(1); 
		printf("%d\n",Max);
		int i;
		for ( i = 0; i < Max -1; i++)  // 记得是要小于当前的最大值,也就是Max
			printf("%d ",ans[i]);
		if (i == Max - 1) printf("%d",ans[i]);
		 printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值