UVA - 10050 Hartals

A social research organization has determined a simple set of parameters to simulate the behavior of the political parties of our country. One of the parameters is a positive integer h (called the hartal parameter) that denotes the average number of days between two successive hartals (strikes) called by the corresponding party. Though the parameter is far too simple to be flawless, it can still be used to forecast the damages caused by hartals. The following example will give you a clear idea:


Consider three political parties. Assume h1 = 3, h2 = 4 andh3 = 8 where hi is the hartal parameter for partyi ( i = 1, 2, 3). Now, we will simulate the behavior of these three parties forN = 14 days. One must always start the simulation on a Sunday and assume that there will be nohartals on weekly holidays (on Fridays and Saturdays).


 1234567891011121314
Days              
 SuMoTuWeThFrSaSuMoTuWeThFrSa
Party 1  x  x  x  x  
Party 2   x   x   x  
Party 3       x      
Hartals  12   34  5  


The simulation above shows that there will be exactly 5 hartals (on days 3, 4, 8, 9 and 12) in 14 days. There will be nohartal on day 6 since it is a Friday. Hence we lose 5 working days in 2 weeks.

In this problem, given the hartal parameters for several political parties and the value ofN, your job is to determine the number of working days we lose in those N days.

Input 

The first line of the input consists of a single integer T giving the number of test cases to follow.

The first line of each test case contains an integer N ( $7 \le N \le 3650$) giving the number of days over which the simulation must be run. The next line contains another integer P ( $1 \le P \le 100$) representing the number of political parties in this case. The i�th of the next P lines contains a positive integerhi (which will never be a multiple of 7) giving the hartal parameter for party i ( $1 \le i \leP$).

Output 

For each test case in the input output the number of working days we lose. Each output must be on a separate line.

Sample Input 

2
14
3
3
4
8
100
4
12
15
25
40

Sample Output 

5
15



题意:

给出天数,以及党的个数,还有罢工的周期,求出最后罢工的天数,星期五以及星期六不算在内;



<pre name="code" class="cpp">#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;

int main()
{
	int n;
	int d;
	int p;
	int a[4000];
	int b[4000];
	cin >> n;
	while(n --)
	{
		cin >> d;
		cin >> p;
		memset(b,0,sizeof(b));
		for(int i = 1; i <= p; i ++)
		{
			cin >> a[i];
			for(int j = a[i]; j <= d; j += a[i])
				b[j] = 1;

		}

		int day= 0;

		for(int k = 1; k <= d; k++)
		{
			if(b[k] && (k +7) % 7 - 1 != 5 && (k +7) %7 + 7- 1 != 6)
				day ++ ;			

		}

		printf("%d\n",day);


	}

	return 0;

}

 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值