1040: 数列求和1

1040: 数列求和1

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 11517   Solved: 8349

Submit Status Web Board

Description

输入一个整数n,输出数列1+1/3+1/5+……前n项的和。

Input

输入只有一个正整数n。

Output

结果保留2为小数,单独占一行

Sample Input

3

Sample Output

1.53

HINT

Source

#include <iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>

using namespace std;

int main()
{
    int n,i;
    double s=0.0;
    scanf("%d",&n);
    i=1;
   while(n--)
   {
       s += 1.0/i;
       i += 2;
   }
   printf("%.2f\n",s);
   return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值