I - Foreign Exchange UVA - 10763

Your non-profit organization (iCORE - international Confederation of Revolver Enthusiasts) coordinatesa very successful foreign student exchange program. Over the last few years, demand hassky-rocketed and now you need assistance with your task.The program your organization runs works as follows: All candidates are asked for their originallocation and the location they would like to go to. The program works out only if every student has asuitable exchange partner. In other words, if a student wants to go from A to B, there must be anotherstudent who wants to go from B to A. This was an easy task when there were only about 50 candidates,however now there are up to 500000 candidates!InputThe input file contains multiple cases. Each test case will consist of a line containing n – the numberof candidates (1 ≤ n ≤ 500000), followed by n lines representing the exchange information for eachcandidate. Each of these lines will contain 2 integers, separated by a single space, representing the candidate’soriginal location and the candidate’s target location respectively. Locations will be representedby nonnegative integer numbers. You may assume that no candidate will have his or her original locationbeing the same as his or her target location as this would fall into the domestic exchange program.The input is terminated by a case where n = 0; this case should not be processed.OutputFor each test case, print ‘YES’ on a single line if there is a way for the exchange program to work out,otherwise print ‘NO’.Sample Input101 22 13 44 3100 200200 10057 22 571 22 1101 23 45 67 89 1011 1213 1415 1617 1819 200Sample OutputYESN
#include <iostream>
#include<cstdio>
#include<cstring>
#include<string.h>
#include<string>
#include<stdio.h>
#include<algorithm>
#include<stack>
using namespace std;
int a[500001];
int b[500001];
int main()
{
    int i,n;
    while(scanf("%d",&n),n!=0)
    {
        for(i=0; i<n; i++)
            scanf("%d %d",&a[i],&b[i]);
        sort(a,a+n);
        sort(b,b+n);
        int f=0;
        for(i=0; i<n; i++)
        {
            if(a[i]!=b[i])
            {
                f=1;
                break;
            }
        }
        if(f==0)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值