UVA 10763 - Foreign Exchange(二分查找)

5 篇文章 0 订阅

B - Foreign Exchange
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Your non-profit organization (iCORE - international Confederation of Revolver Enthusiasts) coordinates a very successful foreign student exchange program. Over the last few years, demand has sky-rocketed and now you need assistance with your task.

The program your organization runs works as follows: All candidates are asked for their original location and the location they would like to go to. The program works out only if every student has a suitable exchange partner. In other words, if a student wants to go from A to B, there must be another student who wants to go from B to A. This was an easy task when there were only about 50 candidates, however now there are up to 500000 candidates!

Input

The input file contains multiple cases. Each test case will consist of a line containing n - the number of candidates (1≤n≤500000), followed by n lines representing the exchange information for each candidate. Each of these lines will contain 2 integers, separated by a single space, representing the candidate's original location and the candidate's target location respectively. Locations will be represented by nonnegative integer numbers. You may assume that no candidate will have his or her original location being the same as his or her target location as this would fall into the domestic exchange program. The input is terminated by a case where n = 0; this case should not be processed.

Output

For each test case, print "YES" on a single line if there is a way for the exchange program to work out, otherwise print "NO".

Sample Input

10
1 2
2 1
3 4
4 3
100 200
200 100
57 2
2 57
1 2
2 1
10
1 2
3 4
5 6
7 8
9 10
11 12
13 14
15 16
17 18
19 20
0

Sample Output

YES
NO

===================================

关于题意的理解需要注意1 2和2 1是YES,1 2、2 3、3 1是NO

思路就是 快排+二分查找


#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;

bool mark[511111];

struct student
{
    int a,b;
}s[511111];

bool cmp(student x,student y)
{
    if(x.b==y.b) return x.a<y.a;
    return x.b<y.b;
}

int search(int key1,int key2,student vis[],int n)
{
    int l=0,r=n-1,m,p=0;
    while (l<=r)
    {
        m=(l+r)/2;
        if(vis[m].b==key1&&vis[m].a==key2)
        {
            p=m;//找到第一个符合相等条件的位置
            r=m-1;
        }
        else if(vis[m].b>key1||(vis[m].b==key1&&vis[m].a>key2)) r=m-1;
        else l=m+1;
    }
    if(p)
    {
        if(!mark[p]) return p;
        else
        {
            while(mark[p]) p++;
            if(vis[p].b==key1&&vis[p].a==key2) return p;
        }
    }
    return 0;//s[0]肯定会先找,所以这里返回0没有什么问题
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0) break;
        memset(s,0,sizeof(s));
        memset(mark,0,sizeof(mark));
        int ok=1;
        for(int i=0;i<n;i++)
            scanf("%d%d",&s[i].a,&s[i].b);
        sort(s,s+n,cmp);
        /*for(int i=0;i<n;i++)
        {
            cout<<s[i].a<<"---"<<s[i].b<<endl;
        }*/
        for(int i=0;i<n;i++)
        {
            if(!mark[i])
            {
                int p=search(s[i].a,s[i].b,s,n);
                //cout<<p<<endl;
                if(p)
                {
                    mark[i]=1;
                    mark[p]=1;
                }
                else
                {
                    ok=0;
                    break;
                }
            }
        }
        if(ok) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值