1138: C语言合法标识符

1138: C语言合法标识符

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 2902   Solved: 1251

Submit Status Web Board

Description

输入一个字符串,判断其是否是C的合法标识符。

Input

输入一个长度不超过50的字符串。

Output

如果输入数据是C的合法标识符,则输出"yes",否则,输出“no”。

Sample Input

8fixafghgjhjhjyuyuyyuyuyu

Sample Output

no

HINT

Source

#include<stdio.h>
#include<string.h>
#include<ctype.h>
int main()
{
    char ch[50];
    int i,l=0;
    gets(ch);
    if(!(islower(ch[0])!=0||isupper(ch[0])!=0||ch[0]=='_'))
    {
        printf("no\n");
        return 0;
    }
    else
    {
        for(i=1; ch[i]!='\0'; i++)
        {
            if(islower(ch[i])!=0||isupper(ch[i])!=0||isdigit(ch[i])!=0||ch[i]=='_')
                l=1;
            else
            {
                printf("no\n");
                return 0;
            }

        }
    }
    if(l==1)
        printf("yes\n");
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值