一千题,No.0109(解码PAT准考证)

PAT 准考证号由 4 部分组成:

  • 第 1 位是级别,即 T 代表顶级;A 代表甲级;B 代表乙级;
  • 第 2~4 位是考场编号,范围从 101 到 999;
  • 第 5~10 位是考试日期,格式为年、月、日顺次各占 2 位;
  • 最后 11~13 位是考生编号,范围从 000 到 999。

现给定一系列考生的准考证号和他们的成绩,请你按照要求输出各种统计信息。

输入格式:

输入首先在一行中给出两个正整数 N(≤104)和 M(≤100),分别为考生人数和统计要求的个数。

接下来 N 行,每行给出一个考生的准考证号和其分数(在区间 [0,100] 内的整数),其间以空格分隔。

考生信息之后,再给出 M 行,每行给出一个统计要求,格式为:类型 指令,其中

  • 类型 为 1 表示要求按分数非升序输出某个指定级别的考生的成绩,对应的 指令 则给出代表指定级别的字母;
  • 类型 为 2 表示要求将某指定考场的考生人数和总分统计输出,对应的 指令 则给出指定考场的编号;
  • 类型 为 3 表示要求将某指定日期的考生人数分考场统计输出,对应的 指令 则给出指定日期,格式与准考证上日期相同。

输出格式:

对每项统计要求,首先在一行中输出 Case #: 要求,其中 # 是该项要求的编号,从 1 开始;要求 即复制输入给出的要求。随后输出相应的统计结果:

  • 类型 为 1 的指令,输出格式与输入的考生信息格式相同,即 准考证号 成绩。对于分数并列的考生,按其准考证号的字典序递增输出(题目保证无重复准考证号);
  • 类型 为 2 的指令,按 人数 总分 的格式输出;
  • 类型 为 3 的指令,输出按人数非递增顺序,格式为 考场编号 总人数。若人数并列则按考场编号递增顺序输出。

如果查询结果为空,则输出 NA

输入样例:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

输出样例:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

 解题思路:

用OB超时了,只拿到19分:

#include <bits/stdc++.h>

using namespace std;

//方便存储,顺便练习OB
struct stu
{
    stu(string s,int num)
    :_str(s)
    ,_grade(num)
    {
        _level = s.substr(0,1);
        _num = s.substr(1,3);
        _date = s.substr(4,6);
        _stu_num = s.substr(10);
    }
    string _str;
    string _level;
    string _num;
    string _date;
    string _stu_num;
    int _grade;
};

//用于1的排序
bool sort1(const stu & a,const stu & b)
{
    if(a._grade != b._grade) return a._grade > b._grade;
    if(a._grade == b._grade) return a._str < b._str;
}

//指令1
void func1(vector<stu> v,string e)
{
    cout << 1 << " " << e << endl;
    vector<stu> res;
    for(auto &elem : v)
    {
        if(elem._level == e) res.push_back(elem);
    }
    sort(res.begin(),res.end(), sort1);
    if(res.empty())
    {
        cout << "NA\n";
    }
    else
    {
        for(auto & elem : res)
        {
            cout << elem._str << " " << elem._grade << endl;
        }
    }
}

//指令2
void func2(vector<stu> v,string e)
{
    cout << 2 << " " << e << endl;
    int res1 = 0,res2 = 0;
    for(auto &elem : v)
    {
        if(elem._num == e)
        {
            ++res1;
            res2 += elem._grade;
        }
    }
    if(res1 != 0)
    {
        cout << res1 << " " << res2 << endl;
    }
    else
    {
        cout << "NA\n";
    }
}

//指令3
void func3(vector<stu> v,string e)
{
    cout << 3 << " " << e << endl;
    map<string,int> m;
    for(auto & elem : v)
    {
        if(elem._date == e)
        {
            auto t = m.find(elem._num);
            if(t == m.end())
            {
                m.insert({elem._num,1});
            }
            else
            {
                ++t->second;
            }
        }
    }
    if(m.empty())
    {
        cout << "NA\n";
    }
    else
    {
        multimap<int,string,greater<>> res;
        for(auto &elem : m)
        {
            res.insert({elem.second,elem.first});
        }
        for(auto &elem : res)
        {
            cout << elem.second << " " << elem.first << endl;
        }
    }
}

int main()
{
    vector<stu> v;
    int x,y;
    cin >> x >> y;
    for(int i = 0;i < x;++i)
    {
        string s;
        int num;
        cin >> s >> num;
        stu man(s,num);
        v.push_back(man);
    }
    int times = 1;
    for(int i = 0;i < y;++i)
    {
        cout << "Case " << times++ << ": ";
        int num;
        cin >> num;
        string s;
        cin >> s;
        if(num == 1)
        {
            func1(v,s);
        }
        else if(num == 2)
        {
            func2(v,s);
        }
        else
        {
            func3(v,s);
        }
    }
    return 0;
}

对照着柳s的代码将map改为unorder_map后仍然超时,于是决定把OB简化,然后就过了

看来以后尽量不能用过于复杂的OB

#include <bits/stdc++.h>

#define _level  substr(0,1)
#define _num  substr(1,3)
#define _date  substr(4,6)
#define _stu_num  substr(10)

using namespace std;

//方便存储,顺便练习OB
struct stu
{
    stu(string s,int num)
    :_str(s)
    ,_grade(num)
    {
    }
    string _str;
    int _grade;
};

//用于1的排序
bool sort1(const stu & a,const stu & b)
{
    if(a._grade != b._grade) return a._grade > b._grade;
    if(a._grade == b._grade) return a._str < b._str;
}

//用于3的排序
bool sort3(const pair<string,int> a,const pair<string,int> b)
{
    return a.second != b.second ? a.second > b.second : a.first < b.first;
}

//指令1
void func1(vector<stu> v,string e)
{
    cout << 1 << " " << e << endl;
    vector<stu> res;
    for(auto &elem : v)
    {
        if(elem._str._level == e) res.push_back(elem);
    }
    sort(res.begin(),res.end(), sort1);
    if(res.empty())
    {
        cout << "NA\n";
    }
    else
    {
        for(auto & elem : res)
        {
            cout << elem._str << " " << elem._grade << endl;
        }
    }
}

//指令2
void func2(vector<stu> v,string e)
{
    cout << 2 << " " << e << endl;
    int res1 = 0,res2 = 0;
    for(auto &elem : v)
    {
        if(elem._str._num == e)
        {
            ++res1;
            res2 += elem._grade;
        }
    }
    if(res1 != 0)
    {
        cout << res1 << " " << res2 << endl;
    }
    else
    {
        cout << "NA\n";
    }
}

//指令3
void func3(vector<stu> v,string e)
{
    cout << 3 << " " << e << endl;
    unordered_map<string,int> m;
    for(auto & elem : v)
    {
        if(elem._str._date == e)
        {
            ++m[elem._str._num];
        }
    }
    if(m.empty())
    {
        cout << "NA\n";
    }
    else
    {
        vector<pair<string,int>> res;
        for(auto &elem : m)
        {
            res.push_back({elem.first,elem.second});
        }
        sort(res.begin(),res.end(), sort3);
        for(auto &elem : res)
        {
            cout << elem.first << " " << elem.second << endl;
        }
    }
}

int main()
{
    vector<stu> v;
    int x,y;
    cin >> x >> y;
    for(int i = 0;i < x;++i)
    {
        string s;
        int num;
        cin >> s >> num;
        stu man(s,num);
        v.push_back(man);
    }
    int times = 1;
    for(int i = 0;i < y;++i)
    {
        cout << "Case " << times++ << ": ";
        int num;
        cin >> num;
        string s;
        cin >> s;
        if(num == 1)
        {
            func1(v,s);
        }
        else if(num == 2)
        {
            func2(v,s);
        }
        else if(num == 3)
        {
            func3(v,s);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值