作者 陈晓梅
单位 广东外语外贸大学
读入n值及n个整数,建立顺序表并遍历输出。
输入格式:
读入n及n个整数
输出格式:
输出n个整数,以空格分隔(最后一个数的后面没有空格)。
输入样例:
在这里给出一组输入。例如:
4
-3 10 20 78
输出样例:
在这里给出相应的输出。例如:
-3 10 20 78
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
#include<iostream>
using namespace std;
struct node
{
int data;
struct node *next;
};
int main()
{
int n;
cin>>n;
struct node *head,*tail,*p;
head= new struct node;
head->next=NULL;
tail=head;
for(int i=0;i<n;i++)
{
p=new struct node;
cin>>p->data;
p->next=NULL;
tail->next=p;
tail=p;
}
p=head->next;
while(p)
{
if(p->next==NULL) cout<<p->data<<endl;
else cout<<p->data<<' ';
p=p->next;
}
return 0;
}