PAT甲级(Advanced Level) Practice 1001 A+B Format

文章介绍了如何在C++中编写代码,计算给定整数之和并按照指定格式(每三位加逗号)输出,涉及基础算法和字符串操作技巧。
摘要由CSDN通过智能技术生成

原题

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where -10^{6}≤ a, b ≤10^{6}. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

题目翻译

计算 a+b 并以标准格式输出总和,即数字必须以三个为一组用逗号分隔(除非数字少于四位)。

输入规范:

每个输入文件包含一个测试用例。每个案例包含一对整数 a 和 b,其中-10^{6} ≤ a, b ≤ 10^{6}, 数字之间用空格隔开。

输出规范:
对于每个测试用例,应在一行中输出 a 和 b 的总和,和必须以标准格式书写。

解题思路

考察字符串处理。由于需要加入逗号, 考虑用字符串来储存a + b。逗号是从低位到高位每隔3位输出一次,考虑倒序存入ans中并倒序输出。注意当a + b < 0时要判断第一位是否为- , 否则可能会出现"-,100,000"此类错误。

代码(c++)

#include <bits/stdc++.h>

using namespace std;

int a, b;
string str, ans;

int main()
{
    cin >> a >> b;
    str = to_string(a + b);
    
    int count = 0;                                                // 确认是否加","
    for(int i = str.size() - 1; i >= 0; i--){
        count++;
        ans += str[i];
        if(count % 3 == 0 && i && str[i - 1] != '-') ans += ",";  // 倒序添加到ans中
    }
    for(int i = ans.size() - 1; i >= 0; i--) cout << ans[i];      // 倒序输出ans, 此时为正序
    
    return 0;
}

  • 8
    点赞
  • 9
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值