PAT甲级(Advanced Level) Practice 1005 Spell It Right

原题

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10^{100}).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

题目翻译 

给定一个非负整数 N,你的任务是计算 N 的所有位数之和,并用英语输出和的每一位数。

输入规范:
每个输入文件包含一个测试用例。每个案例占一行,其中包含一个 N (≤10^{100} ).

输出规范:
对于每个测试用例,用英文单词在一行中输出和的位数。两个连续的单词之间必须有一个空格,但行尾不能有额外的空格

解题思路

考察字符串处理。n的大小为10^{100},所以用char读入每一位直接进行相加。需要从最高位开始依次输出,所以用string存储位数之和sum,构建数组来输出结果对应的英文,注意输出格式。

代码(c++)

#include <bits/stdc++.h>

using namespace std;

int main(){
    char c;
    int sum = 0;
    while(cin >> c) sum += c - '0';
    string ans = to_string(sum);
    string a[] = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};
    for(int i = 0; i < ans.length(); i++){
        if(i == 0) cout << a[ans[i] - '0'];  // 注意输出格式
        else cout << " " << a[ans[i] - '0']; 
    }
    return 0;
}

  • 8
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值