二级指针----藏头诗

本题要求编写一个解密英文藏头诗的程序。建议使用动态内存分配方法处理字符串的输入。

输入格式:

输入为一首英文藏头诗,每句一行,小于20行,每行不超过80个字符,以#作为藏头诗的输入结束标志。

输出格式:

取出每句的第一个字符,连接在一起形成一个字符串并输出。

输入样例:

I come into a dream
Leaves fall down but spring
over a lake birds flying
village have its nice morning
everywhere can feel happiness
Years have never been
owners don't need anything
until the sun bring another wind
#

输出样例: 

ILoveYou
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{ 
    int n=0,i;
    char* poem[20],str[80],mean[20];
    gets(str);
    
    while(str[0]!='#')
    {
        poem[n]=(char*)malloc(sizeof(char)*(strlen(str)+1));
        strcpy(poem[n],str);
        n++;
        gets(str);
    }
    
    for(i=0;i<n;i++)
    {
        mean[i]=*poem[i];
        free(poem[i]);
    }
    mean[i]='\0';
    puts(mean);
    return 0;
}

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值