HNU 实训3-14 魔咒词典

【问题描述】

哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”

【输入形式】

首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含非负整数N(0=<N<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

【输出形式】

每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”

【样例输入】

[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky

【样例输出】

light the wand
accio
what?
what?

知识点:字符串的处理

完整代码:

#include <bits/stdc++.h>

using namespace std;

struct cidian
{
    string zhouyu="";
    string use="";
};

int main()
{
    string z;
    vector<cidian> all;
    int i=0;
    while(getline(cin,z) && z!="@END@")
    {
        string u="",z1="";
        int x=z.find(']');
        z1=z.substr(0,x+1);
        u=z.substr(x+2);
        all.push_back({z1,u});
        i++;
    }
    int t=0;
    cin >> t;
    cin.ignore();
    while(t--)
    {
        string e;
        getline(cin,e);
        if (e[0]=='[')
        {
            int flag1=1;
            for (int j=0; j<i; j++)
            {
                if (e==all[j].zhouyu)
                {
                    cout << all[j].use << endl;
                    flag1=0;
                    break;
                }
            }
            if (flag1) cout << "what?" << endl;
        }
        else
        {
            int flag2=1;
            for (int j=0; j<i; j++)
            {
                if (e==all[j].use)
                {
                    string x=all[j].zhouyu.substr(1,all[j].zhouyu.size()-2);
                    cout << x << endl;
                    flag2=0;
                    break;
                }
            }
            if (flag2) cout << "what?" << endl;
        }
    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
这段引用是一段C++代码,实现了两个多项式的加法。代码首先定义了一个cmp函数,用于比较两个数对的第一个数(多项式的次数)的大小。然后通过vector容器分别存储了两组数对。接下来使用迭代器遍历第一个vector容器中的数对,并在第二个vector容器中查找相同次数的数对,若找到则将第一个数对的系数修改为第二个数对的系数,并从第二个vector容器中删除这个数对。最后,将第二个vector容器中剩余的数对添加到第一个vector容器中,并按照多项式次数的降序对其进行排序。最后,遍历第一个vector容器,按照指定格式输出结果数对。这段代码实现了多项式加法,并按降幂输出结果。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *3* [实训三#3.12多项式加法](https://blog.csdn.net/qq_54256430/article/details/120049796)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] - *2* [HNU软件能力实训3-12. 多项式加法](https://blog.csdn.net/Karltan/article/details/118714616)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值